Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Dell 1600n Printer not showing up in Printer window

  • Please log in to reply
1 reply to this topic

#1 DominicGreco


  • Members
  • 7 posts
  • Local time:04:36 PM

Posted 15 August 2011 - 10:07 AM

I have a Del 1600N Multi function printer that has been in use (successfully) for about two years on my home network. The printer has a built in NIC and is connected via a dedicated 10BaseT line to my network. This printer was working just FINE until I decided to use it as a fax. Some how during that process I must have cleared the network configuration and it stopped being visible on my network.

After some investigation into this I was able to get it back on the network my manually assigning it an IP address. Using the supplied installation DVD, I was able to install the printer onto my two desktop computers (running XP Pro 32 bit) and it works just as well as before.

The problem occurs with my wife's Dell laptop. Before the great "fax fiasco" (as I like to call my stupid attempt to use this printer as a fax machine), the laptop was able to find and print to this printer with very little problems. Now, not so much!

When I went to re-install this printer the first time I made sure that the Dell Printer software was uninstalled (via Control Panel--Uninstall Programs). The first attempt seemed to be going fine. The software detected the printer on the network and it looked like a successful install. However, the test page did not print out! I checked in the "Printer Properties" to make sure that the printer was on line and sure enough, it was. But there was a troubleshooting alert that told me the document didn't print. After several hours of messing with it, I decided to uninstall and try again. The second time went much like the first.

THEN I reasoned that the drivers may be the problem. So I looked on Dell's web site and found the Windows 7 drivers for this printer. I uninstalled the old drivers, downloaded the new ones and then installed. As before it found the printer. But during the install it flashed a message saying that it could not find a file (which was weird). When I hit "continue" it proceeds and looks like it finishes. The network printer monitoring icon appears in the system tray and I can see the 'scanner" portion of this Multifunction Printer. But still, it won't print to it. And in addition, the printer now refuses to show up in the "Printer and Devices Window"!

What am I doing wrong? I've heard that Windows 7 has problems with old printers. But this printer was working perfectly before this! What steps do I need to do to totally remove the old printer drivers and start from scratch? Is there a way to get this printer to be able to work with my wife's Dell Laptop?

BC AdBot (Login to Remove)


#2 DominicGreco

  • Topic Starter

  • Members
  • 7 posts
  • Local time:04:36 PM

Posted 16 August 2011 - 06:52 AM

Well, I fixed it.

part of the problem is that the laptop in question has Windows 7 Home Edition. This version of Windows 7 is missing several of the administrative tools that come with Windows 7 Pro. So there is no way to access the PrintManagement.Msc to locate and delete the printer drivers that were not deleted by the Uninstall.

For this you need to first make sure you uninstalled the software, them to need to open Microsoft Management Console (MMC). Just locate the "Run" dialog box and type in "MMC". Another dialog box will show up. From the listing, locate the drivers you want to delete. There are two options. But I used the one that saws delete drivers and software.

Once they were gone I downloaded the latest 64bit drivers from Dell and then installed them. It worked like a charm.

Hopefully this solution will help some someone else out

Edited by DominicGreco, 16 August 2011 - 06:52 AM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users