Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Canon MP510 won't power up


  • Please log in to reply
3 replies to this topic

#1 Nicki61

Nicki61

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:56 AM

Posted 11 August 2011 - 02:46 PM

I have 6 Canon MP510 printers. All have always been very good.
Until just now. 2 of them won't power up. Changed power cables. Changed cables to the computer. Still nothing.

Is there a reset button? While using it, it just powered down. No reason. Well there is a reason or it would not have powered down...

Any suggestions?

Thanks,
Nicki

BC AdBot (Login to Remove)

 


#2 abauw

abauw

  • Members
  • 951 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Kebun Kelapa
  • Local time:03:56 PM

Posted 11 August 2011 - 03:09 PM

Does any light shown up?

:guitar: Take me to a place where time is frozen
You don't have to close your eyes to dream :busy:
You can find escape inside this moment :smash:
And I will follow  :whistle:


#3 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,541 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:03:56 AM

Posted 11 August 2011 - 04:20 PM

Have you tried removing and reseating the power packs?
In the beginning there was the command line.

#4 mycanon

mycanon

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:56 AM

Posted 29 January 2012 - 11:36 AM

sorry I am new. I replaced my pink color ink and now it will not power up. I have held start a couple of times and it says canon and goes off right away. I have moved and checked the connections on the cords. It is on a strip and it all works but this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users