Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Xp Logging Onto Servers


  • Please log in to reply
7 replies to this topic

#1 davenetd

davenetd

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 11:58 AM

I will try to do my best to describe this problem, but let me know if more info is needed. Here it goes:

I have windows XP Pro machines connecting to servers running OS/400. These machines need constant connections and access to these servers. If for some reason the server does not recognize the user on the machine, windows prompts the user for a username and password that is valid on the server. So far so good, this is typical and not a problem.

So, the logon box pops up and you enter your username and password. You know it's valid, and yet the connection is refused and the logon box pops back up. Here is where the problem starts. Typically the logon box would pop back up because the username or password was incorrect, but in our case it is not. Also normally when the logon attempt is rejected, the logon box pops back up with the rejected username in the box and the password field blank. This is fine except for one little thing. Windows is putting the computer name in the logon box along with the username. It looks like this:

username: computername/username
password: (blank)

This format of putting the computer name infront of the username is incorrect. This problem only exists on very few machines, and only with certain valid server usernames.

What I need:

I need windows to just send the username and password to their server, not the computername. My servers don't care what the name of the computer is just the username and password. Changing anything on the servers is not an option. Is there a way to change the format windows sends logon info to the server? If not does anyone know of any good sites to learn how to write windows scripts to auto logon to servers at startup and put them in the startup. I'm up for registry edits and any other ideas.

One more thing:

When you first get your pc and go through the whole windows setup process, it asks you for a username at the very end of the process in XP. The first username you enter becomes the default. It is my belief that even if you create a new username and delete this original, windows still remembers it and believes that it is the default username when trying to logon to servers. If I am right, Is there somewhere in the registry that you can change the default username from the old deleted one to the new one?


All help and comments are greatly appreciated!
:thumbsup:
Posted Image

BC AdBot (Login to Remove)

 


#2 franktiii

franktiii

  • Members
  • 309 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 02:56 PM

Not sure if this will help, but with Windows Server 2003 when you logon you have user name, password and if you click on options you can choose between logging on to the computer which will give you the computer name/user name setup or you can choose to log on to the network. The next time you log on it remembers your choice from previous log on.

When you install windows you can add a user name or choose not to. If you want to delete that user later, log on as administrator go to control panel/users and delete user use don't want.

Hope this helps

#3 davenetd

davenetd
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 03:22 PM

Thanks Franktiii, but I'm not logging onto a domain. My access request to the server's Integrated File System is being rejected, because windows is sending the username in the wrong format. It needs to be:

Username: john
Password: doe

but it is sending:

Username: JohnsPC/John
Password: doe

All I'm doing is typing "\\servername" (without the quotes) into the address bar of any explorer window. Windows then prompts me for a username and password to gain access to the IFS.

If the UN and PW on the PC matched a UN and PW on the server (which it does) windows should not prompt the user for a UN and PW. However, windows is putting the name of the PC into the username and the server is rejecting it. Then windows prompts the user for the UN and PW. Typically you could just enter the UN and PW and BINGO your in. But NOOOOO! It puts the PC name in automatically. So when you enter the UN and PW it gets rejected and the logon box comes back up. Windows automatically puts the username of the last attempt in the UN field, but prefixes it with the name of the PC. This is WRONG!

Does this make since to anyone?
I am not a Novice, and I am not seeing things. I have seen this happen on other PC's, but all of those PC's were eventually formatted and reloaded because of other problems and they no longer have this problem because the original username for the PC is valid on the server.

PLEASE HELP!
Posted Image

#4 franktiii

franktiii

  • Members
  • 309 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 03:25 PM

Like I said I am not sure what I am offering is applicable, but if you have an option when you log on, not logging on to the computer should prevent it from giving you the computer name/user name format.

#5 davenetd

davenetd
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 03:26 PM

I would just change the username on the server, but the original username has a space in it, and the server does not support usernames with blank spaces in them.
Posted Image

#6 davenetd

davenetd
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 16 January 2006 - 03:31 PM

I just looked to see, but when I click options all I get is an added option to shutdown, not one to log onto a domain instead.

Thanks for your replies and ideas Franktiii!
Posted Image

#7 davenetd

davenetd
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 18 January 2006 - 10:18 AM

I found one work around, but I would still appreciate any ideas on why windows changes the format of the username. Here is the work around.

Map a network drive to the root or home folder of the server. When you do this, there is a link to use a different username. Click this link and use an administrator username and password for the server. Make sure that the box to reconnect at logon is checked and click finish.

This creates some kind of windows script to connect to the server's NFS whenever you logon as the user that the drive is mapped under. This is really simple, but I would rather know how to truely fix the problem.

All ideas are still VERY WELCOME!

Thanks
Posted Image

#8 davenetd

davenetd
  • Topic Starter

  • Members
  • 43 posts
  • OFFLINE
  •  
  • Local time:05:24 AM

Posted 18 January 2006 - 10:20 AM

For some reason, when you use an administrator username and password for the server, windows does not return the signon box with the wrong username format. Weird!
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users