Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

0xc0000142 Errors


  • Please log in to reply
4 replies to this topic

#1 joebeaven

joebeaven

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:01:15 AM

Posted 05 August 2011 - 07:59 AM

Hi,

I'm using Windows 7 Ultimate. I've been using it for some time without problems, but this morning I was unable to get on the Internet. Yesterday I'd installed an update for ZoneAlarm which I thought was probably the problem, so I uninstalled in and downloaded and installed PC Tools Firewall Plus instead. no my computer will connect to the Internet OK, but whenever I try to open most programs, I get the following error:

"The application was unable to start correctly (0xc0000142). Click OK to close the application."

The only two exceptions I've found are Microsoft Security Essentials and Internet Explorer which both work fine.

Please can someone tell me what I need to do to stop this error from appearing?

Thanks,
Joe

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:05:15 PM

Posted 05 August 2011 - 10:53 PM

Did you try system restore to some date from before updating ZA?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 TheShooter93

TheShooter93

    Cody


  • Malware Response Team
  • 4,792 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Orlando, Florida
  • Local time:08:15 PM

Posted 06 August 2011 - 08:10 PM

Here is an thread on a Microsoft forum concerning that error code. Their solution was to try running the program in compatibility mode.

Though it was also mentioned that if it happens with a lot of programs, it could be related to malware.

CCNA R&SCCNA Security | Network+  |  B.S. - Information Technology | Cyber Security Engineer

If I am helping you and have not replied within 48 hours, please send me a private message.

 

 


#4 joebeaven

joebeaven
  • Topic Starter

  • Members
  • 422 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:01:15 AM

Posted 08 August 2011 - 09:38 AM

When I tried running System Restore it failed.

In the end I just decided to restore from my Acronis TrueImage backup image which I made last Monday which meant I had to backup a lot of files that had changed but I managed to get everything restored and I don't think I've lost anything.

I uninstalled ZoneAlarm which worked fine and then I installed PC Tools Firewall again and the problem came back with the same error whenever I tried to open programs. This time I tried restarting in safe mode and uninstalling PC Tools Firewall and it worked. When I restarted in normal mode everything was fine again so I installed the latest version of ZoneAlarm and everything seems to be working fine now.

Thank you for the help and advice.

#5 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:05:15 PM

Posted 08 August 2011 - 07:02 PM

Good news :)
Thanks for posting back....

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users