Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No audio device, can't uninstall drivers


  • Please log in to reply
7 replies to this topic

#1 Mishtyy

Mishtyy

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:06:43 PM

Posted 03 August 2011 - 12:09 AM

I have a problem that's been annoying me for nearly 2 weeks now, and that is that at random times, my computer will crash. That isn't the problem, the problem is that when it reboots, the startup is incredibly slow all of a sudden, and my sound doesn't work. In going to control panel and going to Sounds and Audio Devices, I see "No audio device". When I go to computer management and look at my drivers, everything appears normal, but when I try to uninstall, disable or update my Realtek Ac'97 Audio drivers, it hangs indefinitely after I confirm the removal. I tried going into safe mode and uninstalling, but same results there.

There is a short term fix, which is running a virus scan with avg, then that allows me to uninstall the drivers then everything is okay, but it can happen again several days later. I've been on another site and they already removed any malware from my computer, and they determined the problem isn't malware, but has to be a hardware or software problem. I can't do an XP repair because I don't have the disk, and doing system restore does nothing because I get an error that says the system could not be restored, no changes were made. I have a Compaq presario SR1010z and am using the onboard audio.

edit: adding more details. If I right click the driver, it says it is working properly, even though control panel can't detect it.

Edited by Mishtyy, 03 August 2011 - 03:24 AM.


BC AdBot (Login to Remove)

 


#2 USN Vet

USN Vet

  • Members
  • 190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:43 PM

Posted 03 August 2011 - 01:42 AM

Have you looked at event viewer to see if any errors reported for your crashes ?
(Start, Control Panel, Admin Tools, Event Viewer)

You might also want to check for Soundmax Integrated Digital Audio drivers (XP) for your Compaq.
Solved my problem with Realtek AC97 drivers, but not exactly your problem.
Feel free to ignore my comment, just another user !

#3 Mishtyy

Mishtyy
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:06:43 PM

Posted 03 August 2011 - 02:39 AM

I'm not sure if these are related to the problem, but they were around the time of my most recent crash today, so I'll post them just in case. It happened earlier today while playing half life 2, it hung and I had to restart.

Event Type: Error
Event Source: Application Hang
Event Category: (101)
Event ID: 1002
Date: 8/2/2011
Time: 9:34:47 PM
User: N/A
Computer: COMPAQUSER
Description:
Hanging application hl2.exe, version 0.0.0.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 48 61 6e 67 ion Hang
0010: 20 20 68 6c 32 2e 65 78 hl2.ex
0018: 65 20 30 2e 30 2e 30 2e e 0.0.0.
0020: 30 20 69 6e 20 68 75 6e 0 in hun
0028: 67 61 70 70 20 30 2e 30 gapp 0.0
0030: 2e 30 2e 30 20 61 74 20 .0.0 at
0038: 6f 66 66 73 65 74 20 30 offset 0
0040: 30 30 30 30 30 30 30 0000000

---
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7022
Date: 8/2/2011
Time: 10:07:26 PM
User: N/A
Computer: COMPAQUSER
Description:
The Windows Driver Foundation - User-mode Driver Framework service hung on starting.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

---
Event Type: Error
Event Source: System Error
Event Category: (102)
Event ID: 1003
Date: 8/2/2011
Time: 10:10:03 PM
User: N/A
Computer: COMPAQUSER
Description:
Error code 1000008e, parameter1 c0000005, parameter2 bf278220, parameter3 f23c5844, parameter4 00000000.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 53 79 73 74 65 6d 20 45 System E
0008: 72 72 6f 72 20 20 45 72 rror Er
0010: 72 6f 72 20 63 6f 64 65 ror code
0018: 20 31 30 30 30 30 30 38 1000008
0020: 65 20 20 50 61 72 61 6d e Param
0028: 65 74 65 72 73 20 63 30 eters c0
0030: 30 30 30 30 30 35 2c 20 000005,
0038: 62 66 32 37 38 32 32 30 bf278220
0040: 2c 20 66 32 33 63 35 38 , f23c58
0048: 34 34 2c 20 30 30 30 30 44, 0000
0050: 30 30 30 30 0000

---
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7026
Date: 8/2/2011
Time: 10:17:14 PM
User: N/A
Computer: COMPAQUSER
Description:
The following boot-start or system-start driver(s) failed to load:
AmdK8
BHDrvx86
eeCtrl
Fips
SRTSPX
SymIRON
SYMTDI

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

-----

As to trying that driver, one of my problems is not being able to uninstall the one I currently have, so I doubt it's a problem with the specific driver, plus it can happen even if I'm not using sound, but I'll try it anyway

edit: soundmax drivers wont work, I only get "The audio driver files do not support your computer hardware"

Edited by Mishtyy, 03 August 2011 - 02:53 AM.


#4 Mishtyy

Mishtyy
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:06:43 PM

Posted 03 August 2011 - 03:16 AM

Is there another way to manually remove drivers, like finding the folder where its stored? And to add to my problem, whenever this happens it's impossible to turn my computer off unless I press the power button. If I turn it off properly it gets stuck at "Windows is shutting down..."
I tried updating my driver but that too hangs forever if I try.

#5 Mishtyy

Mishtyy
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:06:43 PM

Posted 03 August 2011 - 10:08 PM

any help would be appreciated, this is a near daily occurrence now and I can't use sound half the time.

#6 Mishtyy

Mishtyy
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:06:43 PM

Posted 08 August 2011 - 01:08 AM

I understand if you can't or aren't going to help, but do you know anywhere else where I can get reliable help?

#7 hamluis

hamluis

    Moderator


  • Moderator
  • 56,435 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:43 PM

Posted 10 August 2011 - 08:17 PM

<<I see "No audio device".>>

Your audio drivers...install your audio device.

The absence of the sound controller/whatever...idicates that you need to install the sound/audio drivers.

You cannot uninstall what is not there.

Let's see if these Realtek drivers you refer to...should even be installed on that system.

System model?

Louis

#8 zcallen1

zcallen1

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:43 PM

Posted 20 December 2011 - 08:54 PM

I'm having a similar issue but it's with most things. not just an audio driver.

I originally had the issue when I swapped a motherboard/cpu/memory. I went from core2duo to i5.

I took precautionary steps removing drivers and everything worked. Some time later...maybe a few weeks this started happening. It hangs when I shut it down and also takes longer than normal to boot(I have an SSD) I cannot uninstall or install most drivers/programs.

I figured it was because of my guts switch. I reformatted and then got everything working. It's been fine for about3-4 weeks but now the problem is back and I cannot find anything that has all of my symptoms.

Any potential solution that fixed this is as good as a lead as I will have in solving this.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users