Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Vista will not install SP1


  • Please log in to reply
4 replies to this topic

#1 HRH RUDI

HRH RUDI

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:41 AM

Posted 28 July 2011 - 09:55 AM

A friend of mine said his computer had been playing up (memory errors, slow etc. he said he thought he had a virus) He doesn't live nearby, so I remoted in via Team Viewer and then logmein. Just to give you the comp info. A Toshiba Satelite A135--s4447 running Vista Home Premium Service pack nothing!!!

Anyhow, I start looking around his system. Can't do anything because of insufficient space. I normally hear memory errors and think virtual memory, but in this case the HD was at its physical limit. He didn't seem to be occupying much with user files and so started getting suspicious. I ran spacemonger and it revealed a blob.bin file (40gb in size) in the windows/winsxs/manifestcache folder. I read up on it and it is a file that caches a bunch of crap and is safe to delete.(I had to take ownership before it would play). So I rebooted, it created itself and took permissions back and got the hard drive operational again.

I ran malwarebytes and superantispyware, a bunch of other cloud based stuff and found and removed a few trojans, some media files that were downloaded with frostwire appeared to have had a bonus included in them, but overall - nothing notable. TDS killers/rootkit checks came back clean.

So after that I checked windows updates and SP1 wasn't there, so I downloaded and ran the full installation to try and save time. It ran quickly until it got about half way and then say there for 15-20 minutes and then it stopped with the error:

"an internal error occurred while installing the service pack error code: 0x800F081F"

So according to the KB and the normal path...I did...

- Chkdsk /r

- sfc /scannow

- Microsoft fix-it for repair the windows update components. It said it had repaired some issues as far as component locations. Restarted, same problem.

- Not sure if this done the same thing, but I re-registered all the dll associated with the windows update services

- Checked and ensured all necessary services and dependencies were enabled/running

- Ran the update readiness tool.

- Disabled AV, closed all other programs out - even tried in safe mode and with a clean boot.

Re-ran update and still the same problem. So I assumed it was something with that particular update. So I went back to automatic updates to do it the old fashioned way.

It only showed .net framework 3.5. So figured I would have to exhaust all normal updates before SP1 would show itself. But .net framework SP1 would not install (can't remember the particular message but it said to try all the above plus the .net framework cleanup tool which I did but it didn't work. So I downloaded the full executable for the net framework and finally got it to install that way.

So now I'm not sure what is the actual culprit hear. SP1 or windows update...or both?!

I re-ran automatic updates and it now showed SP1. So obviously I tried running it that way as well and got the same error.

So that is where I am at. It's driving my nuts as I am normally able to resolve most of these types of issues.

PLEASE, PLEASE, PLEASE....give me something!!!...anything!!!....Yes I have considered a clean install, but that is admitting defeat...plus I'm not there and don't feel like walking them through over the phone. I just want to update this damn machine!!!!

Thats all. Thanks.

BC AdBot (Login to Remove)

 


#2 HRH RUDI

HRH RUDI
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:41 AM

Posted 28 July 2011 - 07:32 PM

I know its been less than 1 full day and I hate to bump, but there have been quite a few threads started after this one that have gotten plenty of replies, so just wondered if anyone had been able to read over mine and had any thoughts?

thanks

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,294 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:41 AM

Posted 29 July 2011 - 07:50 AM

http://windows.about.com/od/windowsosversions/a/windows_vista_SP2.htm

You also mention the existence of malware, which you think that you have neutralized. I would suggest posting a topic in the Am I Infected forum, just to be sure.

It's possible that your initial problems were caused by malware and...insufficient space for Windows to function properly...that's just a guess based on what you have posted.

http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/error-0x800f081f-installing-vista-home-prem-sp1/b55adb13-eede-47eb-a4c8-b61ba0f6c786

http://windows.microsoft.com/en-US/windows-vista/Learn-how-to-install-Windows-Vista-Service-Pack-2-SP2

<<I know its been less than 1 full day and I hate to bump, but there have been quite a few threads started after this one that have gotten plenty of replies, so just wondered if anyone had been able to read over mine and had any thoughts?>>

Just my opinion...but members are under no obligation to respond to a given thread...they all volunteer...their time, suggestions, comments. A given member may read your post...and think that there is nothing that he/she can contribute usefully to the stated issues...which are varied, IMO. Combine that with the fact that you state that you had researched/solved the SP1 issue...and the fact that Google se3ems to indicate that such are not uncommon, per Google review...I'm not sure what the point of your comment may be.

I myself don't use Vista, have never had it installed...but I do know how to use Google to see that the problems installing SP1...seems what I would consider well-documenhted. That documentation doesn't reflect a definitive, easy answer to the problems that Vista users may have.]

http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/navShell.jsp?cf=su_winos

Louis

#4 HRH RUDI

HRH RUDI
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:41 AM

Posted 29 July 2011 - 07:06 PM

I appreciate your response but the links you provide are all in reference to SP2. I am having issues with SP1. I understand that this place is run by volunteers, my comment was just referencing the fact that many others had posted and had gotten multiple replies almost straight away. As far as doing research by my self, I did of course, hence the long list of stuff that I had already tried. I came here because I as hoping to get feedback with someone with more experience than me (which I am sure there are many) or those that have had the same type of problem (also sure there are many of these). The link that you did provide that was relevant was stating to use the update readiness tool, which I said I had done already. Would appreciate any other suggestions.

#5 Keithuk

Keithuk

  • Members
  • 960 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:41 PM

Posted 30 July 2011 - 05:45 AM

Well I've never had a problem installing SP1 or SP2 on my Vista Home Premium 32bit. I have both of these on a flash drive, everytime I do a rebuilt I just run them from the flash drive and they both install without a problem.

Keith

Windows ME (spare computer)
Windows XP 2002 Professional SP3 (desktop computer)
Windows 7 Professional SP1 32bit (laptop computer)

Windows 8 64bit spare drive for laptop computer





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users