Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internal drives showing up as external drives


  • Please log in to reply
5 replies to this topic

#1 x_33

x_33

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 21 July 2011 - 10:20 PM

Hi all. I'm hoping someone could help me with this issue. I just finished putting together my computer, installed Windows 7 Pro 64 bits. However, both of my hard drives (one SSD, one regular HDD) are showing up as external drives (plug-and-play). If I click the "Safely Remove Hardware" icon, I could actually "eject" both of my hard drives. I've searched on Google for clues, but it wasn't helpful. If anyone has any idea on how to fix this, it will be greatly appreciated. Thank you!

Edited by x_33, 21 July 2011 - 10:20 PM.


BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:10:23 PM

Posted 22 July 2011 - 10:29 AM

You have to enable write caching for your internal hard disk.

- Click on Start Menu.
- Type devmgmt.msc and press Enter.
- Locate your hard disk under Disc Drives in the list in Device Manager.
- Double-click on your hard disk.
- Select Policies tab.
- Check the checkbox Enable write caching on this device
- Click OK.

#3 x_33

x_33
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 22 July 2011 - 12:52 PM

Hi Romeo29, thanks for your reply. Both of them have caching already enabled.

#4 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:10:23 PM

Posted 22 July 2011 - 05:07 PM

Are you using nVidia Sata drivers? They often add "remove device safely" for hard disk drives too. But if you actually try to remove such a drive, then it shows error that windows system drive cannot be ejected.
One workaround is to stop using nVidia supplied drivers and use Microsoft drivers that come with Windows.

#5 Syborg

Syborg

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ontario
  • Local time:10:23 PM

Posted 02 January 2012 - 02:54 PM

I have the same problem and solved the issue with this solution.

This is a common problem when running on the generic AHCI driver supplied in Windows 7.
The solution is to install the correct AHCI driver for your computer.

First - find the AHCI driver. These usually come in the motherboard CD if this were a custom build. For a laptop you would need to see if there is one in the manufacturer's downloads section, contact the manufacturer, or find out the brand of motherboard, check the specs, and see if you can find a suitable driver. The generic Intel driver works for many boards based on Intel chipsets and can be found on Intel's website.

Once you have the correct AHCI driver you install it thus:

* Open Device Manager
* Navigate to IDE/ATA/ATAPI Controller > ***AHCI Serial ATA Controller
* Right click > Properties
* Choose: Update Driver
* Browse to the folder that contains the AHCI driver you downloaded > Select > OK
* “Successful” Message > Close
* “Must Restart > Restart
* Drivers Install > Another Restart necessary > Restart
* Drivers successfully Installed. Remove Hardware Icon no longer showing.

The name of the AHCI device is different for different systems, but it should be the only one with AHCI in it's name.

#6 rotor123

rotor123

  • Moderator
  • 8,093 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:23 PM

Posted 02 January 2012 - 05:42 PM

I have also seen this being a setting in the bios on a late model fancy ASUS motherboard where you could set the drive as removable or not removable. Setting the SSD and 1TB to not removable on that friends build solved that issue.

Romeo29, I even saw that in Vista Ultimate with the Nvidia drivers.

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users