Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet Problem


  • Please log in to reply
13 replies to this topic

#1 Kyle03455

Kyle03455

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 15 July 2011 - 07:43 PM

My grandfather has this Windows XP, Compaq Presario and can't get it to connect to the internet at all, although this PC used to be able to connect to the internet. I took it home with me and used the exact same Ethernet cord plugged into my PC (Which does have internet) and put the cord right into the back of his PC instead, and it still won't connect to the internet, nor find a connection at all.

Edited by hamluis, 16 July 2011 - 10:52 AM.
Moved from XP to Win 7.


BC AdBot (Login to Remove)

 


#2 .X.

.X.

  • Members
  • 490 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:47 PM

Posted 15 July 2011 - 07:49 PM

Poke around the Network Connections applet and tell us what you see.

#3 Kyle03455

Kyle03455
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 15 July 2011 - 08:13 PM

I apologize he has Windows 7, not Windows XP. Also the Ethernet cord is lit up.

Attached Files


Edited by Kyle03455, 15 July 2011 - 08:57 PM.


#4 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:10:47 AM

Posted 16 July 2011 - 05:46 PM

At the bottom of that window, click "Troubleshoot problems" and reply back with the result. The troubleshoooter can usually tell you what's wrong.

The ethernet being lit up is a good thing, because it means the hardware is working up to the point of the computer (where we will focus our attention).

Edited by keyboardNinja, 16 July 2011 - 05:47 PM.

PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#5 Kyle03455

Kyle03455
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 16 July 2011 - 10:23 PM

It keeps stating "Local area connection doesn't have a valid IP configuration"

Attached Files



#6 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:10:47 AM

Posted 16 July 2011 - 11:05 PM

Let's see if we can figure out what's going on with your ipconfig.

Hit the following keyboard combination: Windows Key + R

Copy and paste the following into the resulting Run box and hit Enter:
ipconfig /all > %userprofile%/Desktop/ipconfig.txt

On your Desktop, open ipconfig.txt, copy all text and paste into your next reply.

Edited by keyboardNinja, 16 July 2011 - 11:06 PM.

PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#7 Kyle03455

Kyle03455
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 17 July 2011 - 07:28 AM

Screenshot below

Attached Files



#8 Tony4554

Tony4554

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 17 July 2011 - 10:24 AM

It seems that your NIC is functioning. Have you tried to turn off any and All firewalls? If not do so. It may be that you are blocked by the PCs firewall.

After you turn off the firewalls, open a command window. Windows key + R then Type in cmd, a command window opens, then type ipconfig /release then press enter, next type ipconfig /renew then press enter.

Next, see if a successful connection IP has been issued.

Type in the command window ipconfig /all. Does the results show an assigned IP address of 192.168.x.x (192.168.1.x or 192.168.0.x)?

Remember to turn the firewall back on after the test. If you were successful in connecting to the internet or LAN, make sure that you reconfigure the firewall configurations correctly.

#9 Kyle03455

Kyle03455
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 17 July 2011 - 02:15 PM

I disabled the firewall once before and tried to connect, but it still didn't work. I tried again with the steps you listed, but still no luck. It still lists all the same things that the last screenshot I posted shows.

#10 Tony4554

Tony4554

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 18 July 2011 - 02:52 PM

Have you tried to manually set a static IP?
I do not know what the scheme is for your network and router.
To find it, run ipconfig /all on your working computer. Let's say it shows 192.168.1.106 as the IP.
Next, configure your grand fathers computer network adapter with a static IP incremented up one (Ex 192.168.1.107)
Type in all the rest of the subnet, DNS and gateway information. Click ok to close then Reboot.

#11 darklight1

darklight1

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:09:47 AM

Posted 18 July 2011 - 11:39 PM

Your IP is 169.254.30.49, which indicates an issue with DHCP. DHCP is typically handled by the router or modem (depending on his setup) Seeing as there is no default gateway listed either, I'd suspect something with the router that it is plugged into. Have you tried with another computer (eg. laptop) into that same router? Also, go into the properties of the network adapter, look in there and check the IPv4 settings.

#12 hamluis

hamluis

    Moderator


  • Moderator
  • 56,299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:11:47 AM

Posted 19 July 2011 - 09:22 AM

http://www.ehow.com/how_5963613_change-169-ip-address.html

Louis

#13 Kyle03455

Kyle03455
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 19 July 2011 - 10:20 AM

@ Tony--I set up a static IP for his computer, but unfortunately it still wouldn't connect

@ Darklight---All I did was unplug the Ethernet cord that is plugged into the back of my PC and plugged it into the back of his. My PC connects fine to the internet and I never had any problems, all the other computers located throughout my house also connect to the internet just fine as well..so I know the problem shouldn't be coming from the router or modem. All the other computers list a gateway and IPv4 number except this one. --The thing is, is that his PC won't connect to the internet at his house either, although the rest of his PC's in his house do.

Edited by Kyle03455, 19 July 2011 - 10:24 AM.


#14 Tony4554

Tony4554

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 19 July 2011 - 10:58 AM

I repaired a pc about 2 months ago that went through the same type of symptoms.
After I uninstalled the drivers for the network card, then reinstalled them I still had no success.
Last thing to test was the current NIC itself(This was an onboard NIC). I swapped another test NIC into the PC and it worked perfectly.

I disabled the original network card in device manager.
Next, I installed a new NIC (cost $20)
I installed the drivers[was installing on XP box](Win7 should recognize it automatically).
Rebooted and all was good as new using DHCP.

Hope this is your answer




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users