Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New PSU, Now No Video and Won't Post


  • Please log in to reply
No replies to this topic

#1 phoenixcrash

phoenixcrash

  • Members
  • 119 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina
  • Local time:11:20 PM

Posted 11 July 2011 - 05:51 PM

Alright fellas, I got a eMachines T1842 here and the power supply died on it a couple weeks ago. I ordered a replacement power supply. This one here: PSU Link
Waited a week for it to arrive, but when it got here I installed it immediately. Here's where things went wrong...

The new PSU has an On/Off switch on the back that when flicked on, automatically turns the PC on. I have absolutely no control over it using the front power switch. Flicking the switch on the new PSU is also the only way to shut her down.

When I first installed the PSU and turned it on, the green light around the power button would light up the usual green, but the orange CPU light would remain on constantly (it now briefly lights up then goes off). The computer would not POST, I have no video signal being sent to my monitor. The only thing that I've touched on this PC is the power supply. I have however, tried taking it down to the bare essentials: Mobo, CPU & Fan, and one stick of (guaranteed good) RAM. No luck there. Don't think that having a keyboard was 'essential' for this process.

I've read everywhere that I should be hearing 'beeps' that will signify whether or not my setup is assembled properly.
I have yet to hear a single 'beep'. I have cleared the CMOS/BIOS.
Also, I have tried other known-working monitors that give the same 'Check Video Cable' error.

Anyone got any idea what could be going on here? I'm in desperate need of help. Just hope the replies aren't all "your mobo is fried, get a new one".

PC Specs are:
2.3Ghz Intel Celeron
1.5GB of DDR PC2100 RAM
IM845GL Mobo
450-Watt PSU (the one in the link above)
120GB IDE HDD
Onboard Video

Edited by phoenixcrash, 11 July 2011 - 05:58 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users