Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet Explorer 9


  • Please log in to reply
13 replies to this topic

#1 Murrar

Murrar

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 11 July 2011 - 06:21 AM

I have Internet Explorer 9 on my Windows 7 computer. When I click on an e-mail link on a web page a screen comes up stating “Could not perform this operation because the default mail client is not properly installed.” When I had Internet Explorer 8 this never happened. How do I install “default mail client” on Internet Explorer 9? Thank you very much. Murrar

BC AdBot (Login to Remove)

 


#2 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 11 July 2011 - 06:36 AM

Hi Murrar. :)

It's possible the default settings have been changed. Please try this:

  • Go to Start>Control Panel>Programs>Default Programs>Set Your Default Programs.
  • Choose your mail program (ie. Outlook, Live Mail etc) as the default for your email client.
Please let me know how it goes. :thumbup2:

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#3 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 11 July 2011 - 09:08 AM

To Dark Night: I am sorry to say that your method did not work. Can you think of anything else? Murrar

#4 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 12 July 2011 - 02:07 AM

Not a problem. :)

Give this a shot (before proceeding, you may want to save your cookies since the reset below wipes them out via File>Import and Export...):

  • Plase go to Internet Explorer>Tools>Internet Options>Advanced.
  • Click Reset.

If that doesn't work, please do the following:

  • Go to Start>Run and type in the following:

    cmd /k reg query hkcr\mailto /s
  • Please post the results in your next post.

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#5 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 12 July 2011 - 04:10 AM

To Dark Knight: I went to Start/Run and typed in what you said. I got a bunch of lines on the screen. What exactly do I do now? Thank you. Murrar

#6 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 12 July 2011 - 04:27 AM

Hey Murrar,

Right-click and select all the lines and then select Copy.

Paste those lines in your next post. :thumbup2:

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#7 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 12 July 2011 - 09:07 AM

To Dark Knight: I could not copy and paste but I typed it out as follows:

HKEY_CLASSES_ROOT\MAILTO\DEFAULT.com
HKEY_CLASSES_ROOT\MAILTO\SHELL
HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN
HKEY_CLASSES_ROOT\MAILTO\OPEN\COMMAND

Please tell me specifically what to do? Thank you. Murrar

#8 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 12 July 2011 - 05:17 PM

Hi Murrar. :)

Earlier I had you try to choose the default program. This method is similar, but will use a different setting. Try this:

  • Go to Start>Control Panel>Programs>Default Programs>Set Your Default Programs.
  • Click Set program access and computer defaults.
  • Select Custom, and then select your mail client.
  • Click OK.

If this works, the mailto: protocol entry should be restored.

You could also try setting the default through IE itself by following these instructions:

  • Go to Internet Explorer>Tools>Internet Options>Programs.
  • Click Set programs and then click Set program access and defaults.
  • Click Custom and then click the double arrows on the far right.
  • A screen will appear with your computer's current settings. Look at the second option (usually the email program) and manually select the email client you would like to use.

It's possible the Protocol type is not associated with a mail client. Please do this to make sure it is:

  • Go to Start>Control Panel>Default Programs.
  • Click Associate a file type or protocol with a program.
  • Scroll down to find the MAILTO protocol.
  • If it is not associated with your mail client, change it so that it is.

Hopefully one of the above works. If not, we'll go from there. :thumbup2:

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#9 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 12 July 2011 - 07:29 PM

To Dark Night: I clicked “Set You Default Program” but I did not see the words “Set Program Access and Computer Defaults.” Please tell me specifically what to do? Thank you. Murrar

#10 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 12 July 2011 - 07:46 PM

Hi Murrar,

Ok, I did it for mine so here is what you need to do:

When you go through IE and click Set programs you will be taken to a Control Panel window, where you will be presented with 4 options. The one you are looking for is the bottom one.

If you can't see it, please tell me what you can see. :thumbup2:

Edited by The Dark Knight, 12 July 2011 - 07:50 PM.

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#11 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 13 July 2011 - 07:15 AM

To Dark Knight: I clicked Set Your default program and then i saw about 100 items but i did not see mine or the words "other items". Murrar

#12 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 13 July 2011 - 07:21 PM

Hi Murrar. :)

Ok. So when you clicked Set your default programs, did you see a column to the left with a list of programs and to the right a description of the program selected?

From what I understand from your last post, you didn't see your email client in the list of programs?

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image


#13 Murrar

Murrar
  • Topic Starter

  • Members
  • 193 posts
  • OFFLINE
  •  
  • Local time:07:42 PM

Posted 14 July 2011 - 04:39 AM

To Dark Knight: That is correct. I didn't see my email client in the list of programs? Murrar

#14 The Dark Knight

The Dark Knight

    The Magician


  • Security Colleague
  • 661 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Krypton
  • Local time:10:42 AM

Posted 14 July 2011 - 04:50 AM

Hmm Ok. :busy:

Just to check, you are able to use your email client normally, without Internet Explorer? What email client are using by the way?

If you make yourself more than just a man, if you devote yourself to an ideal...you become something else entirely. A legend, Mr. Wayne, a legend!


If I have helped you please consider donating to the Neuroscience Research Institute.


Posted Image
Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users