Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 boot problem


  • Please log in to reply
4 replies to this topic

#1 HomerS

HomerS

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:46 AM

Posted 10 July 2011 - 10:07 PM

Hello all! I've relied on this forum for much advice in aiding me on repairing other peoples computers in the past but this is my first post. This issue is on my own desktop. I have an HP m9350f running Windows 7, and all was fine until I attempted adding a secondary HDD. My intentions were simple, put in another drive and clone the main one to it to prevent the possibility of data loss, backup only. I've done this to other machines in the past with no problems, but this time when I installed the drive (SATA) it was not recognized. I restarted in BIOS and it was being shown there, so when I rebooted I had the option to enter RAID setup. I am still puzzled by this because I don't remember setting up , or even seeing the option when I installed 7 on this machine. I actually have no need (or desire) for a RAID configuration. OK so I entered the RAID setup and that's where my trouble started. I know almost nothing about RAID but I added the new drive in the setup, thinking that it would then show up in the operating system. That turned out to be the wrong thing to do, cause ever since then it won't boot.

So I disconnected the new drive and now I get a blue screen after windows tries to boot telling me to uninstall any new Hard Drives yada yada. I entered the Startup Repair that 7 has and after it ran I got this- "A recent driver installation or upgrade may be preventing the system from starting". I dug through the log file and came up with an error code of 0x0000007b 0x80786b58 0xc0000034. Additionally, 2 restore attempts failed.

Also, somehow I accidentally switched from mirrored to striped RAID, but now I can't seem to get back into the screen to change it back. I remember it asking me if I wanting to change the MBR, but I chose no on that.

Like I said, I really have no interest in a RAID configuration but now I need to get it to boot. I am certain my files and data are intact but I want to ask advice before proceding to prevent further damage.

Thanks in advance for any advice!

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:06:46 AM

Posted 10 July 2011 - 10:35 PM

If you want to see the new hard disk as a separate hard disk drive, then turn off the RAID configuration in the BIOS.
Then do the startup repair using Windows 7 DVD.

#3 HomerS

HomerS
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:46 AM

Posted 12 July 2011 - 07:29 PM

Romeo, thank you for taking the time to help me on this issue. I did what you suggested but unfortunately it didn't work. In my BIOS I disabled the RAID controller but then it wouldn't do anything, including boot from the Windows 7 CD. And yes, I set the CD ROM as boot device 1. So I had to go back in to BIOS and enable the RAID controller. I then booted of the CD and ran the startup repair. I don't know if all Windows 7 versions have the startup repair option, but I actually ran that a couple times without booting off the CD. Anyway, I ran it and got the exact same result as the other times, unable to repair. I had also tried to do a system restore from the startup repair, which also failed. Then I noticed it was possible to restore the system image, which I had from just a little over a month ago on an external HD. Man I thought sure that was going to do the trick but that failed also! I just can't believe this thing was running perfectly until I switched the settings in the RAID, and now I can't change anything back.

Like I said originally, all I did was hooked up the secondary HD, and since it wasn't recognized in Windows I opened the RAID setup (BIG mistake) and added it. Hasn't booted since.

Now I can plug in the second HD, open the RAID setup and it's not even shown in there, so I can't figure out how to reverse what I have done. I can see the second HD in BIOS, but not in the RAID setup. Man this is frustrating.

Oh, one more thing. I dug through the results that came from the attempt to repair, and it seems to me that it is looking for D:/WINDOWS to boot. That makes no sense to me because my original HD has always been C:, and it had never been partitioned. It should be looking to C:/WINDOWS. I have long ago unplugged the second HD so it's not looking for that.

I am more familiar with the XP recovery console than 7, but is there a way I can get into (or does 7 even have) recovery console and do a FIXBOOT or something? Also, when the repair was running it did a diskcheck and all was fine. I also ran the diskcheck in the diagnostics and again it was fine. I just need to get this boot thing straightened out! AAARRRRRGGHH.

#4 georgemac

georgemac

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:04:46 AM

Posted 12 July 2011 - 11:44 PM

Hi, I had the same issue on my gateway, windows 7. My computer got stuck in the same start up repair loop. I couldn't get into safe mode at all or anything. Luckily for my gateway i found out if I hit alt - f-10 during start up I could restore my computer to factory mode. I did that and it seemed to work. However two days later when I went to shut my pc down it said windows needed to do 115 updates. Sure enough when I started it up it went back into that start up loop once and then I was able to get one. I have been searching the net and have seen a lot of posts about this virus. I tried downloading malywarebytes as well as AVG (both free editions) and they did not pick up any virus on the scan.. But I'm sure that it is a virus. I found this link where the person seemed to be able to fix it

http://forums.techguy.org/virus-other-malware-removal/975630-startup-repair-loop-cant-log.html

If this does indeed work, can someone explain how I can do this? can i create the linux disc he talks about for free?? and what is Fedora/how do I do this.

Thanks hope this helps get this thing fixed

#5 Nimblewill

Nimblewill

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:06:46 AM

Posted 13 July 2011 - 06:45 PM

Hi HomerS, no expert here, but if I was in your situation I would download the free Partition Wizard .iso file and burn it to a CD.
Boot from the CD and take a look at your original hard drive. See if your system is on a partition named C:.
If the system is on C: and the boot files are looking for D:, you can change C: to D:. If that works I would make a image of the drive and then work on renaming the partition to C:
By the way, have you tried changing the SATA cable to the port the 2nd drive was connected to after you disabled raid?

Edit: just noticed you mentioned a message about your MBR. Partition Wizard has a option to rebuild your MBR, might wan to try that first!

Edited by Nimblewill, 13 July 2011 - 06:48 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users