Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disabled Secondary Logon Service - Taskbar gone


  • Please log in to reply
7 replies to this topic

#1 norcalkeith

norcalkeith

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 05 July 2011 - 12:45 AM

Computer is a eMachines XP Home Edition - T3092.

Okay, so for some reason last night, I disabled the 'Secondary Logon' service along with another service (RCP related, I'm pretty sure) and set them to 'manual' start - now my tool/taskbar won't come up along with a number of other things not working because of this; Microsoft Security Essentials tells me upon boot that a service has been stopped and gives me the option to start the service, but nothing ever happens after I click to start. I've tried to manage the services, (My Computer, Manage, Services) but there is no option to 'Start' the service (grayed out) and clicking 'Properties' on any service doesn't bring anything up.

I have tried booting into 'Safe Mode' as both a user and Administrator - each time it tells me that System Restore cannot help, and to reboot and try again. This is an old eMachines system with no boot disks either - no back-ups of any sort. I'm pretty sure that I've royally screwed the User profile/s - and can't seem to use my amateur skills to fix the issue this time....

Anybody able to help? I'm gonna call eMachines tomorrow and ask or a Recovery disk, but have tried that in the past and have had issues (can't find their specific eMachines serial number...blah, digressing...)

BC AdBot (Login to Remove)

 


#2 USN Vet

USN Vet

  • Members
  • 190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:15 PM

Posted 05 July 2011 - 04:38 AM

Give this a try - Start, Run, type msconfig.

Click on Services Tab & enable services you stopped.
Feel free to ignore my comment, just another user !

#3 norcalkeith

norcalkeith
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 05 July 2011 - 12:55 PM

Nope - The 'Secondary Logon' doesn't show in the list of services in msconfig.

#4 John Holmes

John Holmes

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Hague, The Netherlands
  • Local time:12:15 AM

Posted 05 July 2011 - 01:50 PM

Can you fall back on a restore point?

#5 bjamrok

bjamrok

  • Members
  • 159 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Illinois
  • Local time:05:15 PM

Posted 05 July 2011 - 02:48 PM

I don't have a copy of xp home running, but I tried to replicate your problem on a virtual edition of xp pro. I can't come anywhere close to replicating it by just disabling the secondary logon service. So is it possible that the other service you said you disabled may be the root of the problem? Assuming that it is not, here is what I would try.

0) Make sure you login with admin priviledges

1) Enter services via start > run > services.msc and under properties of secondary logon service set to automatic and then apply. The start button may become available at this point, if so just click start and disregard the rest. I did notice that when the service is set to disable, the start button is grayed out and the service does not appear in msconfig. Please advise if this fails.

2) Under the logon tab, try using the "this account" option and specify your account name and password. This may allow the service admin privileges to start. remember that when using this box if your computer name is office or home and your username is frank or joe, and your password is 1234, then you enter the username as office\frank or home\joe and the password is 1234.

That's my recommendations for now, as I can't replicate the exact problem, Please post your results and I can try to further assist you.
Sincerely,

Brian

"Thanks to all of you who contribute to open source projects and communities!"

http://jamroktech.blogspot.com

#6 Allan

Allan

  • BC Advisor
  • 8,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:07:15 PM

Posted 05 July 2011 - 03:07 PM

NOTE - the key to the above post is to manage services from start - run - services.msc - NOT from msconfig.

#7 bjamrok

bjamrok

  • Members
  • 159 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Illinois
  • Local time:05:15 PM

Posted 05 July 2011 - 03:15 PM

Yes, exactly. If the service startup type is set to disabled, you wont see it in msconfig.
Sincerely,

Brian

"Thanks to all of you who contribute to open source projects and communities!"

http://jamroktech.blogspot.com

#8 Allan

Allan

  • BC Advisor
  • 8,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:07:15 PM

Posted 05 July 2011 - 03:17 PM

Additionally, msconfig is a diagnostic utility and should not be used to make permanent changes to startup processes.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users