Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox using wrong graphics card for hardware accleration


  • Please log in to reply
14 replies to this topic

#1 Cohensalve

Cohensalve

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 01 July 2011 - 09:25 PM

I just updated my Nvidia graphic card driver to 275.33 version..

But after the update, Firefox 5 chose to use the Intel HD graphics card for hardware accleration instead of the Nvidia graphics card. i checked using about:support and it showed the Intel card being used instead

Is there any way to alert firefox to use the Nvidia card instead ?

Additional Info:
Nvidia GT 425M.
Firefox 5
Optimus Technology present in my laptop

Thanks all =D

BC AdBot (Login to Remove)

 


#2 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 02 July 2011 - 09:50 AM

If you use a dedicated graphics card (Nvidia, in your case), you probably should disable the integrated graphics card (Intel) in the BIOS. Then Firefox won't have a choice. :)
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#3 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 02 July 2011 - 09:45 PM

If you use a dedicated graphics card (Nvidia, in your case), you probably should disable the integrated graphics card (Intel) in the BIOS. Then Firefox won't have a choice. :)


Oh I see.. I will find out how to do it then =). But if I disable the integrated graphics card, it wont be used in any application anymore right ? As sometimes, due to battery issues, I might want to use the integrated GPU for certain applications .

#4 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 02 July 2011 - 10:20 PM

Correct. You could also disable it in the Device Manager (in Windows) if you want to be able to enable/disable on the fly (without a reboot).

Edited by keyboardNinja, 02 July 2011 - 10:21 PM.

PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#5 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 03 July 2011 - 03:00 AM

Correct. You could also disable it in the Device Manager (in Windows) if you want to be able to enable/disable on the fly (without a reboot).


I tried disabling the integrated GPU using device manager.. but my whole screen went black. =X. Requires a forced restart to get it back to normal..

Perhaps the Integrated GPU affects routine stuff too ? =/

#6 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 03 July 2011 - 08:06 AM

I seem to have found a temporary fix.. I right clicked Firefox and chose " run with Graphics Processor " .. Under about:support, it still shows as using Intel HD, but my GPU is in use too. So I guess it should be fine then..

#7 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 03 July 2011 - 09:00 AM

Oops. :whistle: I guess the BIOS is the only proper way to disable it.

Hmph...didn't know you could do that. If you're happy with that, then I guess it's okay. :)
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#8 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 03 July 2011 - 12:19 PM

Argh.. i realised that when I do that, ( I right clicked Firefox and chose " run with Graphics Processor ) , it causes a conflict with the bookmarking system.. Gahhhh.

#9 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 03 July 2011 - 02:05 PM

How odd. :mellow:
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#10 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 03 July 2011 - 09:04 PM

Do you use Firefox as well ? ><. If you do, do you encounter issues with hardware acceleration lol :(

#11 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 03 July 2011 - 09:19 PM

Yes, but I only have one graphics card. lol.

Hardware acceleration really shines when running tests like this: http://ie.microsoft.com/testdrive/performance/fishietank/
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#12 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 04 July 2011 - 07:38 AM

Oh i see.. Yup there's surely a difference of results with and without HA haha..

But based on normal web browsing etc.. Does HA on a dedicated GPU matter alot ? As Firefox's HA can only detect my Intel GPU .. so yeah. :wacko:

#13 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 04 July 2011 - 12:06 PM

Well, from my understanding, HA is only used some of the time (as needed).

I guess the only way to know if there is a performance difference would be to:
1. disable the integrated GPU in the BIOS, run the Fish Tank I linked to above with and without HA turned on, take note of the FPS you get with X number of fish
2. enable the integrated GPU in the BIOS, disable the dedicated, run the Fish Tank again with and without HA turned on (to see if Firefox can even use HA with the Intel GPU)
3. compare the numbers

I get about 36-37 FPS with 500 fish and about 23 FPS with 1,000 fish with HA turned on. Can barely eek out 10 FPS on 100 fish with HA turned off. This is my graphics card, btw.
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#14 Cohensalve

Cohensalve
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:03 PM

Posted 05 July 2011 - 04:31 AM

I tried the test with and without HA ( Intel GPU ) awhile ago.. the differences were pretty great already considering an Intel GPU was used lol.

Gonna disable the Intel GPU and see what happens. But will it cause a black screen like what I did when I disabled it using device manager ? just worried about that though.

#15 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • BC Advisor
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:07:03 AM

Posted 05 July 2011 - 09:52 AM

No, if you disable it in the BIOS, the computer will use the dedicated GPU only.
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users