Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

problem setting up home LAN network


  • Please log in to reply
5 replies to this topic

#1 altern8

altern8

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:01:22 PM

Posted 28 June 2011 - 07:45 AM

hi network gurus. i am having a nightmare trying to solve this problem with my home LAN network. i tried googling almost every forum i could on the internet but still cant find any solution to my issue. i really hope somebody is able to help. :(

i have 2 PCs (1 desktop and 1 laptop) both running Windows XP connected to my modem/router. the desktop is connected through a wireless adapter, and the laptop is connected directly using an ethernet cable. i have run Windows "Network Setup Wizard" on both PCs and they are part of the same workgroup with File and Printer Sharing enabled. this is as far as I've gone in setting up my LAN and everything works fine. i am able to see both PCs under My Network Neighbourhood and can access files from either PC just fine. both PCs are also able to ping each other by IP address and comptuer name.

the problem is this only lasts temporarily. for some reason, after a random amount of time (anywhere between 1 hour to a few days) the desktop will "drop off" from My Network Neighborhood on the laptop. when i try to click on the desktop or workgroup in Network Neighbourhood i suddenly get the error "You might not have permission to use this network resource. Contact the administrator of this server to find out if you have permissions. The network Path was not found." after this happens i am no longer able to ping the desktop from the laptop either by the IP address or computer name.

however I am still able to ping the laptop from the desktop by IP address and computer name, although in Network Neighbourhood the laptop can no longer be seen as part of the workgroup. I am still able access the laptop and its files from the desktop using the \\*computer name* command and this will bring up the laptop name again in Network Neighbourhood.

one more thing i noticed is, once I've pinged the laptop from the desktop i found that i can again ping the desktop from the laptop, but only with the IP address. If I try to ping the desktop by computer name it still times out. howeer, this also lasts temporarily... after a while, the laptop is also not able to ping the desktop IP address again.

the only solution so far is to restart the router. once the router restarts and both PCs reconnect to it, then the LAN is working fine again... that is, until the problem above starts up once again! :angry:

my modem/router model is D-Link DSL-2640B

some additional info:
- i've assigned static IPs to both PCs so they always have the same IP address from the router.
- i've tried disabling the built-in Windows firewall on both PCs but the problem remains.
- i do not have any other anti-virus or firewall programs installed.
- i've disabled "Computer Browser" service on the laptop so that the desktop is always the Master Browser (some forums said this might help but it didn't).

does anyone know what the issue could be? i'm not even sure if it's an issue on the desktop, laptop or something to do with the router. i am prepared to get a new router but i'm not sure if that is the answer.

BC AdBot (Login to Remove)

 


#2 wiczjr

wiczjr

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Local time:11:22 PM

Posted 30 June 2011 - 04:51 PM

Since you set up static IPs, I'm wondering if one of your neighbors is connecting to your router and messing things up. Did you secure it?
Both faith and fear may sail into your harbour, but only allow faith to drop anchor.

#3 Baltboy

Baltboy

    Bleepin' Flame Head


  • Members
  • 1,432 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:01:22 AM

Posted 01 July 2011 - 10:05 AM

How did you set the static Ip address? If you set them on the computers the problem may lie with how the router handles its routing table. If possible assign the addresses using DHCP reserved addressing in the router. This way the addresses will recieve all of the benefits of DHCP while retaining the same IP address whenever they are turned on.

Edited by Baltboy, 01 July 2011 - 10:06 AM.

Get your facts first, then you can distort them as you please.
Mark Twain

#4 dirtdog900

dirtdog900

  • Members
  • 86 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:22 AM

Posted 05 July 2011 - 03:45 PM

I would suggest a few things... Make sure you are running SP3 and all patches and try updating the network card drivers, it sounds like you have basic networking ok as you can still ping by ip. It sounds more like a netbios problem as the resolving by name seems to cause the most problems. You could make sure you have 'enable netbios over tcp/ip' checked under the advanced networking settings, although I suspect you may have done this already as it works for a while. Rebooting the router doesn't really fit in with the overall problem unless that stops passing the netbios traffic for some reason, so maybe a check for any newer firmware here.

The netbios name resolving only sometimes - suggests they may still be arguing over a master browser. Have you checked your event logs for any mention of this? Have a look on both pc's for any errors. I would enable the computer browser service on the laptop again though.

#5 altern8

altern8
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:01:22 PM

Posted 12 July 2011 - 04:31 AM

hi. thanks everyone for your replies and help. sorry it took me a while to reply. i think dirtdog may have been right in suspecting the modem since resetting it seems to temporarily resolve my problem. this doesn't really fit in with any other scenario related to the PCs. i have updated the firmware of my modem and so far the network has been stable for the last 5 days. too early to celebrate but it's looking good. i'll report back if things start to fail again.

thanks again guys! :)

#6 s1lents0ul

s1lents0ul

  • Members
  • 544 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:22 AM

Posted 12 July 2011 - 09:17 AM

If possible assign the addresses using DHCP reserved addressing in the router. This way the addresses will recieve all of the benefits of DHCP while retaining the same IP address whenever they are turned on.


This modem/router does not support this, its missing the ability to assign specific IP addresses to particular pieces of equipment (preferrably by MAC) - for instance.

I do not know a solution to your problem, sorry.
==]--s1lents0ul-->




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users