Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB thumb drive recognized in rear USB port but not in USB hub


  • Please log in to reply
3 replies to this topic

#1 landen99

landen99

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 27 June 2011 - 11:09 PM

My USB thumb drive is recognized quickly and normally when plugged into the rear USB port (motherboard) but not when connected into a port on my USB hub (also connected to a rear port). This issue occurs currently in Win7 x86, 8 Gb RAM, but I have seen this issue happen in Win XP too. Device manager shows no device driver issues. While plugged into the USB hub, the USB drive lights up, but nothing happens and it seems to slow system file operations and log on and off operations greatly. The hub works fine for all other devices attached and switching the port on the hub does not affect the issue.

More details on this issue:
Computer restart does not resolve the issue.
When plugged into the hub, Kaspersky AV (KIS) scans the drive but only recognizes one file, but when plugged into the back, KIS scans the drive and sees thousands of files. The scan takes the same amount of time to complete. I can't see what that one file is, though, in the former case.

I read a Microsoft resolution listing three methods, including manually detecting new hardware on the USB Root (Device manager) and restarting the computer (this latter option has failed has failed). I will report back this evening on which devices connected to the USB hub work correctly while experiencing this USB thumb drive failure on the port.

I am dying to figure out the problem in the hopes of solving this issue and perhaps avoiding crawling to the back of the tower for every plug and unplug operation. What are your experiences and ideas about this issue?

Edited by landen99, 28 June 2011 - 08:33 AM.


BC AdBot (Login to Remove)

 


#2 s1lents0ul

s1lents0ul

  • Members
  • 544 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:10 PM

Posted 30 June 2011 - 08:50 AM

Does the USB hub plug into the wall for power, or only powered by the usb port?

Do you have any thing else plugged into the HUB, if it is only powered by USB port then this might be the issue.

I think its a power issue. Have you tried other USB items in the HUB to verify it works correctly?
==]--s1lents0ul-->

#3 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,545 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:12:10 PM

Posted 30 June 2011 - 05:42 PM

I think its a power issue with the hub as well.

You could get a USB extension cable, plug it into the back and run the other end to the front for easy access.
They are only about 10 bucks or so.

Does this system not have usb ports on the front as well?
Most do these days.
In the beginning there was the command line.

#4 landen99

landen99
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:10 PM

Posted 02 July 2011 - 01:04 AM

The USB hub is powered by plug. Other devices work well on it. This computer is running low on non-hub USB ports, so even an extension cord is not ideal. The two front ports work, but I have to get out of my chair and kneel down low to the ground to install the USB thumb drive.

I have tried the USB drive in several USB hub ports and found that it works in all but the first port on the hub. I have not tested if other devices work on the port, but I am guessing that we already have a good idea how other devices will likely respond to that port as well. Maybe it has just broken due to mechanical wear and tear. It has been in use for many years.

Edited by landen99, 02 July 2011 - 01:11 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users