Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sound disappears when computer is unplugged from electric supply.


  • Please log in to reply
2 replies to this topic

#1 guiliker

guiliker

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:37 PM

Posted 26 June 2011 - 12:28 PM

I have been having sound problems for about three days now.

The problem started as:
Switched on Windows XP Pro SP3 partition (at that point I was dual booting with Ubuntu 11.04) on start-up I got an error message saying "Sonic Focus driver must be loaded for this application to work". This was meaningless to me until I realised that there was no sound and no sound card in Device Manager>Sound Video and Game Controllers.

So I googled and I found a guide on an Intel page about reinstalling the audio driver from disc. I can't find that page now but it was about uninstalling the software via Add/Remove Programs, disabling audio in the bios and reinstalling from CD. I attempted this but got an error message "Device Object not present, restart the system and run setup again" and it wouldn't install. I got mad thinking I had done something wrong with the entire Windows installation and decided to do a fresh install.

On fresh install from a XP Pro SP2 disc.

I switched off audio at the bios prior to the Windows Install and then installed the device drivers from the Intel DQ965COE (D75503-001) disc in the following order:
1. Chipset INF [INF_ALLOS_8.0.1.1002_PC]
2. Audio [5.10.5143_XP32_XP64_MCE_v1]
3. LAN [LAN_11.1_ALLOS_PV]
4. Video and something else through Device Manager

On attempting to install the Audio driver I got the same error message as last time: "Device Object not present, restart the system and run setup again". I then tried to install the new driver [AUD_allOS_D20001.0x_PV_IDTGUI_v105_Legacy] from: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=13706&ProdId=2373&lang=eng&OSVersion=Windows%20XP%20Professional*&DownloadType=Drivers This produced the following error message "The hardware detected is not supported by this IDT software package. The install was aborted." I tried re-anabling sound in the bios and then installing and had the same error message.

I got annoyed with having no sound and so I installed an Audigy 2 sound card (Model: SB0240, driver: Creative Sound Blaster Audigy series driver 2.18.0017 from: http://support.creative.com/Products/ProductDetails.aspx?catID=1&subCatID=205&prodID=149&prodName=Audigy%202&subCatName=Audigy&CatName=Sound+Blaster&VARSET=prodfaq:PRODFAQ_149,VARSET=CategoryID:1#) and I had sound. Then when I restarted and tried the Ubuntu 11.04 Live CD and there was no sound.

I restarted Windows and installed the Intel audio driver [5.10.5143_XP32_XP64_MCE_v1] from disc. This worked and I had sound through both the Audigy 2 card and the onboard Intel chip. Device Manager showed a Sigmatel High Definition Audio Codec under "Sound Video and Game Controllers" however I forgot to print screen it so do not have any further details. When I shutdown and took the Audigy 2 card out of the PCI slot and restarted I still had sound. I then shutdown again and switched on then I had no sound. The codec was no longer listed in Device Manager and Device Manager was not recognising any uninstalled devices.

When I attempted to re-install either of the Intel drivers I got the same error messages as they had previously given.

I shutdown and returned the Audigy 2 card to the PCI slot and switched on; this time getting a shrill beep on any attempt to play sound. I then installed the Intel driver [AUD_allOS_D20001.0x_PV_IDTGUI_v105_Legacy] from the website which worked this time. I shutdown and removed the Audigy 2 card. I switched on and had sound. I restarted and had sound. I thought fixed! I removed the Audigy 2 software via Add/Remove Programs. However when I shutdown and removed the electric plug of the computer and restarted I once again had no sound and no sound card recognised in Device Manager.

I returned the Audigy 2 card to the PCI slot and when I restart the Intel driver reappears and sound works even after unplugging from the electric.

So to sum it all up, I am confused and need help with:

1. Why won't the Intel software install unless the Audigy card is present?
2. How come the Intel software remains after the Audigy card is removed, but disappears either on shutdown and switch or after unplug?
3. Where does the Intel software go when the Audigy card gets removed?

Given guidance I can provide any information needed to sort this.


from http://www.intel.com/support/siu.htm
SYSTEM INFORMATION
Computer Manufacturer Intel Corporation
Computer Model DQ965CO
Operating System (O/S) Microsoft Windows XP Professional Service Pack 3
Operating System Build (O/S) (build 2600)
Operating System (version) 5.1.2600
O/S Language 0809
System RAM 1005.8 MB
.NET Framework Version not detected
CD or DVD Device TSSTcorp CD/DVDW SH-S182D
System Hard Drive Overview
System Total Storage Size: 29.4 GB
Physical Drive 0
Maker
Model HDT722516DLA380
Bus Type ATA
Local Disk C: 29.4 GB
Used space: 9.6 GB
Free Space: 19.8 GB
Memory Detail
Total Physical Memory 1005.8 MB
Available Physical Memory 269.2 MB
Total Virtual Memory 2.0 GB
MOTHERBOARD INFORMATION
Manufacturer Intel
Model DQ965CO
AA Number AAD46480-501
BIOS Vendor Intel Corp.
BIOS Version MQ96510J.5​4T.0013.20​06.1009.17​01
BIOS Release Date 10/09/06
System Memory 1005.8 MB
Built-in Audio Driver Component not detected
Built-in Audio Driver Version 5.10.20001.0
Built-in Audio Driver Status Device is unknown or unsupported

BC AdBot (Login to Remove)

 


#2 guiliker

guiliker
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:37 PM

Posted 26 June 2011 - 09:13 PM

Sorry about posting in the wrong forum I didn't see the AV forum.

I thought I should post the fix I have found. I've been trawling google for the various error messages and somehow happened upon this page: http://forums.cnet.com/7723-6122_102-340889.html While I was not getting a "code 10" error I thought I'd try it and it worked!

This is what I did:
Removed the Audigy 2 card, switched on and went to "C:\Program Files\IDT\WDM" and double clicked on suhlp.exe and selected "run anyway" when it said a disc was missing from the D:\ drive. Shutdown and switched on. It worked! I've unplugged twice and it is still working. I wonder if doing this would have solved the original error message "Sonic Focus driver must be loaded for this application to work"...

Edited by guiliker, 26 June 2011 - 09:18 PM.


#3 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:03:37 PM

Posted 26 June 2011 - 10:55 PM

Thank for taking the time to post the fix, guiliker. :thumbup2:
It could prove helpful to someone else, having the same problem.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users