Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"open with"


  • Please log in to reply
2 replies to this topic

#1 deer2011

deer2011

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Franklin, TN
  • Local time:05:11 AM

Posted 20 June 2011 - 08:26 AM

Hello everyone; last week my computer was infected with malware, which I removed via your "How to remove XP Security Tool...........Uninstall Guide" article. It was very helpful.

Here's the complicated thing (complicated to me) about it:

Now, when I am trying to open certain applications via desktop icon (such as AutoCAD or Windows Explorer or Google SketchUp); it sends me to an "Open With" application.

One thing that I deviated from in your malware removal instructions: I was logged in as my own name when the malware would pop up and keep me from opening anything. I had to log in as "administrator" in order to install Malwarebytes' AntiMalware. When I was logged in as administrator, the malware popups were not showing. Should I have run MBAM while the popups were showing?

or is this "open with" just a control panel issue? Help as soon as possible would be greatly appreciated; I need AutoCAD to work this morning. Thanks so much! Dan C.

BC AdBot (Login to Remove)

 


#2 whoabuddy

whoabuddy

    Bleepin' Verbose


  • Malware Response Instructor
  • 2,053 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cottonwood, AZ
  • Local time:02:11 AM

Posted 20 June 2011 - 09:48 AM

Hi Dan,

Can you open any applications? Or do they all give you the same "Open With..." dialog? If so, I reviewed this tutorial on removing XP Security Tool from B-C, and next to the MBAM download link is another for FixExe.reg. From what you are describing it sounds like the malware changed your EXE file association so that you cannot launch applications, and this registry script should fix that for you. Download and save this file to your desktop, and here are the instructions from the guide:

double-click on the FixExe.reg file. When Windows prompts whether or not you want to allow the data to be added to your computer, click on the Yes button.

The file itself changes some registry keys that are specific to the user that is logged in, so by logging into the Administrator account you weren't able to correct this for your profile. I'm sure it wouldn't hurt to run another full scan with MBAM updated too just to be safe!
Meditate. Elevate. Appreciate. | "Life is a journey, love is the destination, happiness is the path!"
If I am helping you and have not responded within 48 hours, please send me a PM.
Vi Veri Universum Vivus Vici (VVVVV)
Excellent Security Advice
Proud member of UNITE

#3 deer2011

deer2011
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Franklin, TN
  • Local time:05:11 AM

Posted 21 June 2011 - 10:13 AM

Thank you....I am at home at the moment with my own virus!! When I get back to the work computer, I will try your suggestion. The applications that I could open were things like, Microsoft Excel, Word, and I could go online. I will report back on what happened. Tx, Dan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users