Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help Me Please


  • Please log in to reply
2 replies to this topic

#1 snowleopard

snowleopard

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:09 PM

Posted 08 January 2006 - 09:08 PM

:thumbsup: [b] [size=2]Hi all just found forum and need help..I have an emachine that last nite i think it died. The light in the tower flickers really fast and makes a strange noise, but nothing on screen..I think it is either possessed or dying. Any help before i lay it to rest? Thanks :flowers:

BC AdBot (Login to Remove)

 


#2 bicycle bill

bicycle bill

  • Banned
  • 339 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:09 PM

Posted 08 January 2006 - 09:31 PM

Sorry but you will have to give more info than this to hope to ellicit a reply to your problem.

#3 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:05:09 PM

Posted 08 January 2006 - 10:33 PM

bicycle bill is right, we will need more information. The processor, amount of RAM, computer model number. To be honest it sounds like your power supply may have failed. Emachines use a non-standard power supply.
"2007 & 2008 Windows Shell/User Award"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users