Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft Windows Network Finding Other Pcs That I Dont Recognize


  • Please log in to reply
5 replies to this topic

#1 WillieMac

WillieMac

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:05:18 PM

Posted 08 January 2006 - 06:19 PM

I have 2 PCs, I want to share files between them and the printer, and I want to play Nascar via LAN.

I have created the network to do the file sharing using the Networking Wizard with XP. All was well except that I noticed that there were names of PCs that I did not recognize. And I was able to open these shared folders to see someones summer vacation photos and such. This I did not want as I suspected that I was shareing my files and my PC with who knows who. I figured it had something to do wtih the default networking group name (MSHOME) so I made up my own group name. That seemed to end it and all was well until recently. By way of this site I downloaded a free firewall called Zone Alarm and have been trying to configure it but am having trouble still accessing the network so I turned it off. I now have someone elses shared files available on my PCs that are listed under the My Network Places/Entire Network/Microsoft Windows Network. how does this happen? how do I remove this folder (wont delete) and how do I create a network that no one else can get into and will stay out of and yet maintain a firewall to keep the evil from gettin to my PC?

BC AdBot (Login to Remove)

 


#2 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:10:18 AM

Posted 09 January 2006 - 03:40 AM

What you have described is a great example of why everyone should enable wireless encryption on their networks.

You started on the right track by changing the workgroup name because everyone's workgroup starts as mshome, so unless you change it you're inviting everyone else to be a member of your workgroup.

You have two PCs with wireless cards (NICs) in them?
There is no wireless router or access point involved?

Turn off Zone Alarm while you do the following.
You need to define a name for your wireless network - called the SSID.
I think you have to manually enter the SSID on both NICs and, if asked choose the Ad-Hoc networking.
Your network will then be a bit more exclusive but anyone who "sees" it can still join it if they want.

Now you need to set up encryption on your network - what options you have depends on the manufacturer and type of NIC that you have. The best encryption to choose is WPA-PSK but I don't know if that is available with Ad-Hoc setup. If not choose WEP encryption. Usually you have to type in a number or a passphrase to generate encryption keys. Whichever it is write it down and store it somewhere safe so that when you come to add a third PC you will know what your encryption key was.

After you have entered the same data on both PCs you should have your network back operating but this time without any of your neighbours shared folders available.
If that all looks good you can set up Zone Alarm on both PCs.

Click Start>Run then type cmd and hit enter.
In the black window that opens type ipconfig

Depending on your network you should see headings like:

"Ethernet adapter Local Area Connection" or "Ethernet adapter xxx Wireless Connection" or similar.

Below each of these headings will be a list of names followed by numbers, such as:
"IP Address..........:192.168.0.3"
"Subnet Mask.........:255.255.255.0"
"Default Gateway.....:192.168.0.1"

- there may be other entries. Make a note of all the "IP Address" numbers and "Default Gateway" numbers.

You should have two IP addresses for your PCs and you need to enter those addresses or that range of addresses in the Zone Alarm's "Trusted Zone" . I don't have Zone Alarm at the moment so I cannot 'talk you through it'. Your best bet is to go to the ZA help or their website for instructions.
http://www.zonelabs.com/store/content/supp...en&lid=zasupp_h

hth :thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#3 WillieMac

WillieMac
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:05:18 PM

Posted 09 January 2006 - 11:00 AM

Hello Rimmer, thanks for the reply. Neither PC is wireless, both have cables. I have ethernet on each PC and am running them thru a Lynksys Wireless - G Broadband Router.
It says it has Up to 128-bit encryption, powerful SPI firewall, but I really know nothing about that and have found no evidence to suggest it is blocking anything. I have only used the XP firewall until this Zone Alarm. It could be that one of my sons' friends had their wireless laptop nearby and I picked up his shared forlder, or perhaps someone near my house. Scary either way.
And it is their group that I am seeing (other than mshome). besides my own.
please be patient with me, this stuff is quite complicated for the likes of this old grey matter. thanks

When booting up my other PC this morning, I get a Smard Defense Advisor on my screen from Zone Alarm that it is blocking internet access to this PC from it. I have yet to figure out how to manage this problem.

Edited by WillieMac, 09 January 2006 - 11:17 AM.


#4 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:10:18 AM

Posted 10 January 2006 - 03:06 AM

Okay... your PCs are not wirelessly connected but they are still part of a wireless network because of the Linksys router. So you need to turn on the security of the wireless router to prevent outside access.

Turn off Zone Alarm on the PC you are going to use for now.
Access the routers configuration page by typing an IP address in the Address bar of your web browser (Internet Explorer or Firefox) - the address will be in you Linksys manual. It will look as though you have gone to a web page but you are actually talking to the router. Enter the username and password (usually admin & admin) and then you are in the router configuration area. Again your manual will describe this better.
You need to define a name for your wireless network - called the SSID.
Now you need to set up encryption on your network. The best encryption to choose is WPA-PSK but if that is not available choose WEP encryption. Usually you have to type in a number or a passphrase to generate encryption keys. Whichever it is write it down and store it somewhere safe.
If there is an option for 'broadcast SSID' you may want to disable this so your network is not "advertised" all over the neighbourhood.
That should be it. The wireless part of your network is encrypted so only computers set up with the encryption key can connect to it. And you cannot connect to computers that don't have the right key either so your son's friend's holiday snaps will no longer be available.

The firewall in the router is there to block intruders from the internet accessing your PCs, it will have no effect on the operation of your local network (wired or wireless).

If everything still works well you should set up Zone Alarm on both PCs:

Click Start>Run then type cmd and hit enter.
In the black window that opens type ipconfig
Depending on your network you should see headings like:

"Ethernet adapter Local Area Connection" or "Ethernet adapter xxx Wireless Connection" or similar.

Below each of these headings will be a list of names followed by numbers, such as:
"IP Address..........:192.168.0.3"
"Subnet Mask.........:255.255.255.0"
"Default Gateway.....:192.168.0.1"

- there may be other entries. Make a note of all the "IP Address" numbers and "Default Gateway" numbers.

You should have two IP addresses for your PCs and you need to enter those addresses or that range of addresses in the Zone Alarm's "Trusted Zone" . I don't have Zone Alarm at the moment so I cannot 'talk you through it'. Your best bet is to go to the ZA help or their website for instructions.
http://www.zonelabs.com/store/content/supp...en&lid=zasupp_h

:thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#5 WillieMac

WillieMac
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:05:18 PM

Posted 11 January 2006 - 11:04 AM

Thank you Rimmer, I followed your intructions and now I can network the two PCs and run Zone Alarm at Medium so I believe I am protected somewhat. And I disabled the wireless so I am not broadcasting in the neighborhood. I really appreciate all your help and time, its amazing, this site and the people linked all over the world.

Edited by WillieMac, 11 January 2006 - 11:05 AM.


#6 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:10:18 AM

Posted 11 January 2006 - 06:17 PM

That's good news! :thumbsup:
You're welcome.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users