Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

print spooler won't stay on?


  • Please log in to reply
20 replies to this topic

#1 zjz2

zjz2

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 04 June 2011 - 09:15 PM

Hi,

So a few days ago I tried to print something, and it said I had to install a printer. Odd, since I have a printer installed. So I went to my Printers & Faxes, and it showed none (not even the pdf printer or XPS Document Writer, etc). I click Add a Printer and it says that my print spooler is stopped. I'm running XP Home SP3.

I've done loads of searching and tried everything I can find:

- I go over to services.msc and restart the print spooler, it says it's starting, and then that it's running. Nonetheless, if I try to add a printer I get "Operation could not be completed."

- I've run sfc /scannow

- Event viewer shows lots of Service Control Manager error 7031, which states: "The Print Spooler service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service." (The "6 times" is what this one says, the others have other numbers.)

- System restore keeps failing.

I've tried loads of other things I found people mention online, but nothing seems to work...any help would be greatly appreciated!!

BC AdBot (Login to Remove)

 


#2 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 04 June 2011 - 09:50 PM

Hi,

Under services.msc, what is the startup type of the print spooler?
Before the issue started to happen, do you recall any update from any software? (ex: windows update, printer driver update, etc)

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#3 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 05 June 2011 - 03:28 PM

Thanks booterbotter. It's set to automatic startup. I don't think I installed any new software. I know I didn't install any new printers.

Thanks again.

#4 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 05 June 2011 - 03:53 PM

Hi,

Can you provide us more information about your computer and your printer?
-Windows XP service pack and edition. (ex: WinXP Pro SP3)
-Printer model being used on the computer. (ex: Epson Stylus Photo R2880, hp laserjet 1020)

What type of connection are you using for the printer? (ex: Usb direct connection, wireless etc.)

What application were you using when you got the error?

Do not run any software to try and fix the issue.

*edit
reason = added some more information

Edited by booterbotter , 05 June 2011 - 04:00 PM.

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#5 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 05 June 2011 - 05:14 PM

I'm using XP Service Pack 3. The printer I'm using is a Brother MFC 7840-W using a wifi network connection. However, I installed the printer along time ago, and it's been working fine since then, and another computer on the network is connected to the printer with no problem. Also, the fact that all the printers, including the pdf printer, disappeared, makes me think it's not something related to my actual printer.

Not sure what you mean by what application I was running. I think I was trying to print a webpage, or Word document. The error just says that there's no printer connected, then when I checked, I saw there were no printers listed as installed. I tried adding a printer which is when I got the print spooler error. But I had to look at the event viewer to see the actual error that it keeps trying to restart.

The only software I ran was the Microsoft FixIt application, which didn't work. It just tried to restart the print spooler, which I had already tried.

Thanks again!

#6 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 05 June 2011 - 06:00 PM

Hi,

So your OS is fully patched.
Is this computer hookup wireless to your router? Just curious.

Try the following steps.

-Turn off the printer
-Start the print spooler service

IF

it starts, try to check the print queue (printers and faxes) for pending docs and delete them (I know its kinda vague since the print spooler service is stopped so there should be no pending docs however you did mentioned the printer is setup wireless and that you sent a print queue previously so this is why I wanted you to check that.)

if you have a remote control software running on the background in your task manager, end the process first before doing the steps above.


ELSE

Check the event viewer and post the error you are getting.

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#7 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 05 June 2011 - 06:51 PM

The computer hookup is wireless to the router.

I turned off the printer and started the spooler. It says it started, but then when I went to add a printer,it says Operation could not be completed." I checked the event viewer and it shows this error:

"The Print Spooler service terminated unexpectedly. It has done this 438 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service."

#8 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 05 June 2011 - 08:55 PM

It just says operation could not be completed or there is a complete error message after that statement?
Do you see any error code in the event viewer?

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#9 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 05 June 2011 - 10:17 PM

That's the whole error message. The error code in the event viewer is 7031.

#10 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 05 June 2011 - 11:17 PM

Just some clarification.
When you started the print spooler and you havent tried adding a printer yet, do you see the other printer icons or their still not appearing?
Go to services.msc and look for plug & play and remote procedure call (RPC), are both the services setup properly?

It's kinda odd for the printer not to work suddenly and at the same time your system restore is not working.

Is there an error message when you try system restore?
The print spooler would only stop working if something was changed on the system or a dependent service is not running.
Do you notice anything else aside from the print spooler service and system restore not working?
There is a possibility were dealing with something else.

You clarified the printer is working on a different computer, it seems its either of the following.
-Connection of your computer to the printer.
-printer Driver or something else in the OS causing the issue.

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#11 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 07 June 2011 - 06:53 PM

- The printer icons did not appear when I started the print spooler.

-Both plug & play, and RPC (and RPC Locator) are started and set to automatic

- The error message on system restore says that it could not be restored to [the date] and no changes were made, and that I could try a different date. I've tried lots of dates going back a month and I get the same result.

It is odd. The only thing is that I had a trojan virus a couple weeks ago that Symantec cleaned, I didn't think that could impact the print spooler though

#12 booterbotter

booterbotter

  • Members
  • 299 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pearl of the Orient
  • Local time:03:54 AM

Posted 07 June 2011 - 09:10 PM

We will need more information about your computer.
Please provide the manufacturer name and model.
If you do not know, click start > run and type msinfo32.exe
Post the first 9 lines you see from there.

Next, pull up your command prompt and type in net stop spooler and once you see the message "The Print Spooler service was stopped successfully."
type in net start spooler.
If you get an error please take note of it, check the event viewer and post the error or message you get.

Now lets go in the add/remove programs.
-Uninstall the drivers for your Brother AIO.
-If the printer is connected with a usb cable, disconnect it. If it is hook up on your router wireless then you can skip this part.
-Restart the computer.
-Reinstall the driver using the CD/DVD that came with your product. (I know each printer manufacturer differs in the way a wireless printer installs, so just make sure we are setting up the printer to install on this computer wireless and not reconfiguring the way it is already established in your network.)

Here's your printer manual if you do not have one.
user manual
network setup manual


If you get an error on any part of the installation, please take not of it, check the event viewer and post the error or message you get.

-yoh

Patience is a true virtue. Never give up, never surrender.
BleepingComputer.com Message Board Rules


#13 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:07:54 PM

Posted 07 June 2011 - 11:51 PM

Please perform the following, so that we can get the exact specs of your computer. This will better assist us in helping you more.

Publish a Snapshot using Speccy

The below is for those who cannot get online

Please take caution when attaching a text file to your post if you cannot copy/paste the link to your post, you will need to edit it to make sure that your Windows Key is not present.

Edited by cryptodan, 07 June 2011 - 11:52 PM.


#14 zjz2

zjz2
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:54 PM

Posted 08 June 2011 - 04:38 PM

Here's the system info:

OS Name Microsoft Windows XP Home Edition
Version 5.1.2600 Service Pack 3 Build 2600
OS Manufacturer Microsoft Corporation
System Name XPS
System Manufacturer Dell Inc.
System Model MXC062
System Type X86-based PC
Processor x86 Family 6 Model 14 Stepping 8 GenuineIntel ~1830 Mhz
BIOS Version/Date Dell Inc. A01, 5/11/2006

I ran net stop spooler, then net start spooler at the command prompt. It said it was started successfully, but then I looked into the event viewer and saw an information entry that it was started, and then one second later an error entry that says this:

The Print Spooler service terminated unexpectedly. It has done this 1671 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

I'll uninstall and reboot and post the results in a few minutes.

Here's the system info:

OS Name Microsoft Windows XP Home Edition
Version 5.1.2600 Service Pack 3 Build 2600
OS Manufacturer Microsoft Corporation
System Name XPS
System Manufacturer Dell Inc.
System Model MXC062
System Type X86-based PC
Processor x86 Family 6 Model 14 Stepping 8 GenuineIntel ~1830 Mhz
BIOS Version/Date Dell Inc. A01, 5/11/2006

I ran net stop spooler, then net start spooler at the command prompt. It said it was started successfully, but then I looked into the event viewer and saw an information entry that it was started, and then one second later an error entry that says this:

The Print Spooler service terminated unexpectedly. It has done this 1671 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

I'll uninstall and reboot and post the results in a few minutes.

#15 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,541 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:02:54 PM

Posted 08 June 2011 - 05:11 PM

Have you tried uninstalling then reinstalling your printer drivers yet?
I believe you said earlier that there is nothing in the printers.
If that is the case the drivers arent installed or may have been corrupted.

Go into control panel - add/remove programs and uninstall everything relating to your printer.
Disconnect the USB cable from either the back of the computer or printer (whichever is easier)
Reboot
Then reinstall the drivers & plug the USB cable in when prompted

Try that & see if it takes care of the problem.
In the beginning there was the command line.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users