Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need Help with win 3.11 System.ini File


  • Please log in to reply
5 replies to this topic

#1 august22

august22

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 04 June 2011 - 05:05 PM

I installed Dos 6.22 and Win 3.11 on a partician that is 2.1 gigs in size. when I type WIN to run windows
I get the following error message. " PageOverCommit value in SYSTEM.INI is too large.
Decrease the value, or if not present, add a setting less than 4."

I have edited the system.ini file and do not see any pageovercommit value. Anyone know what it means?
Thanks for any help in advance.

BC AdBot (Login to Remove)

 


#2 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:08:09 PM

Posted 04 June 2011 - 07:36 PM

It's been about 20 years since I last used Windows 3.1 so I've forgotten most of how it worked.

However, Google suggests that that particular error will be generated if your computer has more than 256MB of RAM and the PageOverCommit setting in SYSTEM.INI is missing or larger than 4.

Try adding this on a new line at the end of the SYSTEM.INI file:

PageOverCommit=1


#3 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,540 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:10:09 PM

Posted 05 June 2011 - 12:07 PM

It goes in the [386 Enh] section.
Set it to 4 initially and then back it down by increments of one if it doesn't work.
Capitalization is important.
It must be exactly
PageOverCommit= (value)

But I am thinking that the problem might be a virtual memory setting.
From DOS try deleting the 386spart.par and the spart.par files in the Windows folder.
Thats the 3.1 swap file. If it is corrupt Windows wont load.
Windows will recreate it.

Also try defrafmenting the hard drive from dos.

In all the years I worked with 3.1 I have never had to add that line though.
How much memory is on the system?

Edited by Eyesee, 05 June 2011 - 12:33 PM.

In the beginning there was the command line.

#4 august22

august22
  • Topic Starter

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 05 June 2011 - 12:52 PM

Thank You Andrew and Eyesee. You fixed my problem.

#5 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,540 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:10:09 PM

Posted 05 June 2011 - 02:44 PM

Good deal! :thumbup2:

Which one worked?

Was it the swap file or the system.ini file?
In the beginning there was the command line.

#6 august22

august22
  • Topic Starter

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 06 June 2011 - 07:44 PM

It was the system.ini file.
Thanks again




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users