Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB problems


  • Please log in to reply
5 replies to this topic

#1 gwlively

gwlively

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:45 AM

Posted 31 May 2011 - 06:20 PM

When I connect my external hard drive I get this message:
"This device can perform faster. The USB device can perform faster if you connect it to a Hi-Speed USB 2.0 port. For a list of available ports, clik here.
After I "click here" I get
"There are no Hi-Speed USB host controllers installed on this computer."
I have Windows XP with Service pack III installed. The problem just started recently; the external hard drive worked fast. Also my mp3 player's flash drive would recharge quickly. Now it complains and charges slowly.

Thanks for your help.

BC AdBot (Login to Remove)

 


#2 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:12:45 PM

Posted 01 June 2011 - 07:55 AM

Go to Device Manager.
Scroll down as needed until you see Universal Serial Bus Controllers.
Expand that by clicking on the boxed plus sign in front of Universal Serial Bus Controllers.

Should see something like 'Standard Enhanced PCI to USB Host Controller' - key is the word 'Enhanced'.
If it's 'Enhanced', it's USB 2.0. If it's not, then it's USB 1.1.

How old is your computer; you may need a USB 2.0 expansion card.
USB 2.0 introduced in 2001.

On the other hand, it may just be a problem with your USB controllers, so you could uninstall them all through Device Manager and reboot for automatic reinstall and then check the list again.

Edited by petewills , 01 June 2011 - 09:02 AM.


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,388 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:45 AM

Posted 01 June 2011 - 09:42 AM

As Pete suggested...go to Device Manager, uninstall all USB controllers (not hubs, not devices...controllers) and then reboot.

Louis

#4 gwlively

gwlively
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:45 AM

Posted 01 June 2011 - 10:26 AM

The problem was in my BIOS. The USB 2.0 Hi-Speed setting had been disabled. Everything is working fine now. Sorry if I mislead anyone. I appreciate everyone's help.

#5 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:12:45 PM

Posted 01 June 2011 - 10:38 AM

Thanks for letting us know. It's another possible solution to add to the general list.
Wonder how it became disabled?

#6 gwlively

gwlively
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:45 AM

Posted 01 June 2011 - 04:23 PM

I had the computer in the shop for repair and while there they changed out the CMOS battery. I assume that the BIOS defaulted to the original settings.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users