Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

.net Framework 2.0 install problem XP SP3


  • Please log in to reply
11 replies to this topic

#1 Emile

Emile

  • Members
  • 123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brussels
  • Local time:01:24 AM

Posted 30 May 2011 - 10:02 AM

Hello,
Having some problems with Windows Update. I was requested by Microsoft Support to uninstall ALL the .net Framework installed on my PC.
When I request the install of Net 2.0 I receive almost at the end of the installation the following popup.. see attached.

Retry does not solve the problem.
Cancel starts the roll back of the installation.

Any recommendations?
Thanks in advance

Attached Files


Emile Asus P7P67 Pro v3, Intel 1155 3.4 GH, Corsair DDR3 8Gb,PCX Nvidia 560 ti,PCX Nvidia 550 ti,
SSD 120Gb, 2 x 1 Tera SATA6, Dual Boot

BC AdBot (Login to Remove)

 


#2 petewills

petewills

  • Members
  • 1,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:06:24 AM

Posted 30 May 2011 - 10:12 AM

Have a look at this topic

http://www.bleepingcomputer.com/forums/topic399678.html

Uninstalling all, cleaning up and reinstalling the 3.5 .net framework can help.

#3 Emile

Emile
  • Topic Starter

  • Members
  • 123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brussels
  • Local time:01:24 AM

Posted 30 May 2011 - 11:32 PM

Hello petewills,
I have used that tools as suggested by microsoft to clean the installed versions of .NET framework.
When I try to install the 3.5 I have the following error , see attached screenshots
URL=http://imageshack.us/photo/my-images/534/net6.png/]Posted Image[/URL]

Posted Image

I am in a "catch 22" situation ..

Thanks in advance

Edited by Emile, 30 May 2011 - 11:34 PM.

Emile Asus P7P67 Pro v3, Intel 1155 3.4 GH, Corsair DDR3 8Gb,PCX Nvidia 560 ti,PCX Nvidia 550 ti,
SSD 120Gb, 2 x 1 Tera SATA6, Dual Boot

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,876 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:24 AM

Posted 31 May 2011 - 06:44 AM

Do you have MS Visual Studio installed?

If so, uninstall it...then reinstall it. It installs the applicable MS.NET version required by it to function properly, no separate install is needed.

Louis

#5 Emile

Emile
  • Topic Starter

  • Members
  • 123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brussels
  • Local time:01:24 AM

Posted 31 May 2011 - 07:15 AM

Hello,
MS Visual studio is not installed, I never did install it.

More recommendations?
Thanks in advance.
Emile Asus P7P67 Pro v3, Intel 1155 3.4 GH, Corsair DDR3 8Gb,PCX Nvidia 560 ti,PCX Nvidia 550 ti,
SSD 120Gb, 2 x 1 Tera SATA6, Dual Boot

#6 petewills

petewills

  • Members
  • 1,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:06:24 AM

Posted 31 May 2011 - 08:23 AM

I've looked up the error messages from your Posts #1 and #3.
There are many suggestions, but I would only be prepared to try them on my own computer, if I had the problem.
I would not be comfortable recommending untried fixes.

So, I suggest trying again.
Uninstall all versions of the .net framework and cleanup as before.
Go to Windows Update and install the frameworks again. You will see in the topic mentioned in my Post #2
that the OP there had his problems resolved by updating in between each install, may work for you.

If you still have problems, I think you may have to go back to Microsoft. I believe support for update problems
is free.

#7 utopian86

utopian86

  • Members
  • 87 posts
  • OFFLINE
  •  
  • Local time:02:24 PM

Posted 31 May 2011 - 09:33 AM

http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/error-25007-while-trying-to-install-microsoft-net/08398609-fefb-454d-95b7-70a98495000b


there is a guide here. hope it helps

#8 hamluis

hamluis

    Moderator


  • Moderator
  • 55,876 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:24 AM

Posted 31 May 2011 - 10:15 AM

That error you cited...clearly indicates that Visual Basic either has been installed or someone attempted to install it...and that is where the error is occurring.

Visual Basic does not install itself.

Louis

Worth a look, http://blogs.msdn.com/b/joy/archive/2008/09/11/net-framework-3-5-sp1-fails-to-install.aspx .

Edited by hamluis, 31 May 2011 - 12:59 PM.


#9 Emile

Emile
  • Topic Starter

  • Members
  • 123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brussels
  • Local time:01:24 AM

Posted 31 May 2011 - 10:23 AM

Hello petewills and utopian86,
response to
Pete : I have used the uninstall tool several times and after I still have the same error popups.
Since 1 week I wait for Microsoft Support response . My case (problem) is registraded but no answer....
Utopian86 : I tried this install but I receive the error "prerequisite program is NOt installed ...Microsoft .NET Framework 2.0 "
I am in the catch 22 situation
Posted Image

I am ready to try more ....But what?
Thanks in advance
Emile Asus P7P67 Pro v3, Intel 1155 3.4 GH, Corsair DDR3 8Gb,PCX Nvidia 560 ti,PCX Nvidia 550 ti,
SSD 120Gb, 2 x 1 Tera SATA6, Dual Boot

#10 petewills

petewills

  • Members
  • 1,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:06:24 AM

Posted 31 May 2011 - 11:38 AM

Hi Louis

What's the last bit of Post #8, after 'Frankly, if you don't' - it's not coming up on my screen.
My mistake, a mini-thought which I canceled :), now deleted ~ Hamluis.

Emile
Perhaps it was stating the obvious; I tend to go at problems, again and again, until they are solved.

So, I have nothing further to add, sorry, but do look at the links mentioned, in #7 and #8;
there may be something there, otherwise, you may just have to be patient with MS.

Edited by hamluis, 31 May 2011 - 01:01 PM.


#11 Emile

Emile
  • Topic Starter

  • Members
  • 123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brussels
  • Local time:01:24 AM

Posted 02 June 2011 - 12:03 AM

Hello,
I have received an answer and instructions from Microsoft Support And there is HOPE !!
I have the 3.5 installed now I will check if my application do work.

The instructions : see attached


IT IS SOLVED !! ALL IS OK
Thanks for your help
Regards ;)

Attached Files


Edited by Emile, 02 June 2011 - 09:52 AM.

Emile Asus P7P67 Pro v3, Intel 1155 3.4 GH, Corsair DDR3 8Gb,PCX Nvidia 560 ti,PCX Nvidia 550 ti,
SSD 120Gb, 2 x 1 Tera SATA6, Dual Boot

#12 petewills

petewills

  • Members
  • 1,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:06:24 AM

Posted 02 June 2011 - 12:22 PM

Emile

Thanks for posting the MS solution with the useful batch commands, which have worked for you.
Hope you have no further problems with the .NET Framework. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users