Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HP Laptop DV2000


  • Please log in to reply
5 replies to this topic

#1 Darkone121

Darkone121

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 19 May 2011 - 03:20 PM

So I have a HP Laptop Dv2000, one day, I decided to plug in the charger, nothing. The light around the input where you plug in the charger doesn't even light up blue. The laptop does not turn on AT ALL! I used a different battery that works fine, didn't plug in the charger (battery only). Still nothing.

So I decided to take apart the laptop, and bake it in the oven since I been hearing that works and resolders all the connections. But before I did, I plugged in only the power to the motherboard. And plugged in the charger, and what do you know? It light up, and so did the LED on the motherboard. (Everything else that was connected to the motherboard is unplugged). Now, when I plug in the screen cable into the Motherboard along with the power, it doesn't want to start up anymore, plugging the screen into the motherboard causes it to shut off and the Blue Light goes away. Not sure whether the cable for the screen is bad? Or the input on the motherboard FOR the screen is bad? Or what...

Does anyone know why this is happening? It's really weird.

Edited by Darkone121, 19 May 2011 - 03:22 PM.


BC AdBot (Login to Remove)

 


#2 AstroIROC

AstroIROC

  • Members
  • 136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Martinsburg, WV
  • Local time:07:02 PM

Posted 19 May 2011 - 03:50 PM

This laptop is a model that is affected by the video card overheating problem that alot of hp laptops do!! But please don't bake it in an oven you will toast it for sure. I have repaired several of these using a heat gun to reseat the video chip but there are a lot of percautions that are needed to ensure that you don't fry or melt anything. Then to complete the repair a 1mm copper shim needs to be installed between the chip and the heatsink to take up the airgap that the flawed design leaves in an unalterd laptop. This is probally not your problem anyway since all the ones I've seen try to power up without video (black scree) or some sort of messed up graphis symptoms. Always the lights come on as it tries to power on, that's why i think this is not yor problem!! Since you have the board out pay close attention to the DC power jack and make sure that it looks good (unbroken pins and or solder joints) wiggle the adapter as its plugged in and see if the lights blink on and off, indicating a bad jack. Good Luck
I am hungry for knowledge

#3 caperjac

caperjac

  • Members
  • 1,649 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NS. CAN
  • Local time:08:02 PM

Posted 19 May 2011 - 07:39 PM

Then to complete the repair a 1mm copper shim

sorry to butt in,i have one that needs fixing , where would i buy 1mm copper shim and the heavy aluminum foil need for the repair
thanks

My answers are my opinion only,usually


#4 Darkone121

Darkone121
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:02 PM

Posted 19 May 2011 - 08:34 PM

The power jack works fine. Its just when i plug the screen cable into the motherboard. The entire motherboard shuts down. Like i said its really odd.

For example. I plug in the jack to the motherboard. Plug into the wall. Motherboard and power circle lights up blue. As soon as i plug the laptop screen into the motherboard. The lights and everything shut off.

Why is that?

#5 AstroIROC

AstroIROC

  • Members
  • 136 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Martinsburg, WV
  • Local time:07:02 PM

Posted 19 May 2011 - 09:26 PM

I really don't know the answer to that! Try unplugging the LCD screens inverter board maybe it is shorting out. You will have to take apart the screen bezels to get to it. Good luck The shims can be bought on ebay search for "DV shim"
I am hungry for knowledge

#6 caperjac

caperjac

  • Members
  • 1,649 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NS. CAN
  • Local time:08:02 PM

Posted 20 May 2011 - 05:15 AM

The power jack works fine. Its just when i plug the screen cable into the motherboard. The entire motherboard shuts down. Like i said its really odd.

For example. I plug in the jack to the motherboard. Plug into the wall. Motherboard and power circle lights up blue. As soon as i plug the laptop screen into the motherboard. The lights and everything shut off.

Why is that?


you should not be plugging the lcd plug in when the laptop is turned on

My answers are my opinion only,usually





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users