Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SATA hard drive in HDD enclosure won't initialize


  • Please log in to reply
1 reply to this topic

#1 boostergold

boostergold

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:54 AM

Posted 19 May 2011 - 11:44 AM

I have a Seagate Momentum 7200.3 HDD (SATA) 320GB that stopped being recognized on my laptop (it was the only HDD on the laptop). I placed it into a SATA/USB HDD enclosure, and when I connect it to another laptop, the LED comes on and the HDD hums like it's spinning(no clicking or other noises), but it does not show up as an external drive. When I go into computer management, I can see the enclosure but it will not initialize the MBR.
Is there any hope for retrieving my data? What step should I take next? Any help is GREATLY appreciated!

BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:54 AM

Posted 21 May 2011 - 01:22 AM

Are you able to see the hdd at all or just the enclosure?

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users