Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Notepad Folder Opens


  • Please log in to reply
24 replies to this topic

#1 Scarlett

Scarlett

    Bleeping Diva


  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 03 January 2006 - 10:17 PM

My Notepad folder opens when I try to view a webpage source.

I found this fix, and would like to try it.

------------------------------------------------------------------------------------------------------------------------------

http://windowsxp.mvps.org/ie/viewsrc.htm

Notepad folder opens when you attempt to view the source of a web page?

Symptom
When you visit a web page, and then click the View menu and select the Source command, Internet Explorer may open the Notepad folder present in the Desktop, rather than displaying the source code of the web page.




Rename the Notepad folder present in the Desktop


Or

Set a View Source Editor with explicit Path, in the registry. Follow these steps:

Click Start, Run and type Regedit.exe

Navigate to the following location:

HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Internet Explorer \ View Source Editor \ Editor Name

Note: If the above branch does not exist by default, you need to create the Keys up to the level above.

In the right-pane, double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE

Close Regedit.exe


Edited by Scarlett, 03 January 2006 - 11:11 PM.

Posted Image

BC AdBot (Login to Remove)

 


#2 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 03 January 2006 - 11:01 PM

Okay, try it then. :thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#3 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 03 January 2006 - 11:02 PM

:thumbsup: Rimmer

I created a backup first. :flowers:

Now when I navigated to:

HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Internet Explorer \ View Source Editor \ Editor Name

The part in bold is not there.

So now I have to:

Note: If the above branch does not exist by default, you need to create the Keys up to the level above.

In the right-pane, double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE


Hmmm.. Im not quite sure how to do this.

I highlighted the "Internet Explorer" key

Then in the right pane "{default} is at the top.

Whe I double click on it I see

"Modify"

"Delete"

"Rename" <--- is grayed out

So do I choose "Modify"?

Edited by Scarlett, 03 January 2006 - 11:07 PM.

Posted Image

#4 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 03 January 2006 - 11:14 PM

No you don't change any existing values.

Highlight the 'Internet explorer" key in the lh pane then click 'Edit', "new" and 'key'

Now you will have a new key under 'Internet explorer' which you may have to rename "View Source Editor "

then edit that key to add a key under it called "Editor Name"

then In the right-pane, double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE

that's the way I read it anyway.....

I created a backup first.

*cough* well naturally I meant you to do that first *cough*

Edited by Rimmer, 03 January 2006 - 11:18 PM.


Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#5 Dngrsone

Dngrsone

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Location:Centrally located far from everywhere
  • Local time:07:58 AM

Posted 03 January 2006 - 11:17 PM

Rightclick teh right pane, you should get a "New" dialog. You want a new key, called "View Source Editor" then select that key, rightclick the right pane and create a new key called "Editor Name"

Then double click that key and enter the value (path to whatever you want to use to edit with).

I'm not sure I understand what the problem is, though... the default editor is notepad unless you have installed an HTML editing program, and those usually make themselves the default editor.

Alternatively, you could open up Tools, Folder Options in any Explorer window, select the File Types tab and scroll down to the extension in question (sorry about that) and click Advanced. Edit the Edit Action (no helping the one) and enter the path to the editor of your choice. This would probably be a lot safer than hacking away at the registry.

<edit> Dang, Rimmer beat me... darn me and my spellchecking... BTW, entering the path to notepad will just ensure you are using notepad as an editor, and I thought you were trying to get away from that. Or am I misreading the problem?</edit>

Edited by Dngrsone, 03 January 2006 - 11:19 PM.

Posted Image

#6 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 03 January 2006 - 11:26 PM

Dngrsone - I think the problem is Scarlett does not see the source at all, just some whacky "notepad folder" opens but I'm not sure as I havn't seen the problem.

(what's a "notepad folder"? :thumbsup: )

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#7 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 03 January 2006 - 11:35 PM

My windows notepad.exe folder opens instead of the page source.


No you don't change any existing values.

Highlight the 'Internet explorer" key in the lh pane then click 'Edit', "new" and 'key'


After I done that a new right pane showed with only > Name {Default} > Data {Value not set}

Now you will have a new key under 'Internet explorer' which you may have to rename "View Source Editor "


Ok I see > New Key #1

then edit that key to add a key under it called "Editor Name"


Now Im lost. How do I edit the new key to add a new one called "Editor Name"?

then In the right-pane, double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE


How do I set data as it says? Right click and then:
> New > Key > String Value > Binary Value > DWORD value ( Which one?)

Edited by Scarlett, 03 January 2006 - 11:38 PM.

Posted Image

#8 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 03 January 2006 - 11:42 PM

Ok I see > New Key #1


Right-click on that and rename it "View Source Editor"

Then highlight it, if it isn't already, and click Edit>new>key then you should get 'New Key #2' or similar under 'View Source Editor', right-click that and rename it to "Editor Name".

click on 'Editor Name' and in the rh pane double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE

Make any sense? :thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#9 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 03 January 2006 - 11:47 PM

I think so. Let me give it a whirl.

Ok

double-click (default) and set it's data as follows
C:\Windows\NOTEPAD.EXE


How do I set its data to C:\Windows\NOTEPAD.EXE

Choices are:

Data > {value not set}> New > Key > String Value > Binary Value > DWORD value ( Which one?)

Edited by Scarlett, 03 January 2006 - 11:50 PM.

Posted Image

#10 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 03 January 2006 - 11:52 PM

When you navigate to:
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Internet Explorer \ View Source Editor \ Editor Name

in the rh pane double-click on the word "Default" under 'Name' and a dialog box should open asking you what the value is you want. There you put "C:\Windows\NOTEPAD.EXE" (without quotes).

I didn't explain that bit before, sorry.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#11 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 03 January 2006 - 11:57 PM

Ok I did that :thumbsup:

Lets see how it goes. lol
Well the stupid Notepad.exe folder still opens when I click on > view > source

Maybe a restart... or a reboot...

Edited by Scarlett, 03 January 2006 - 11:59 PM.

Posted Image

#12 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 04 January 2006 - 12:01 AM

I'd guess you'd at least have to restart IE.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#13 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 04 January 2006 - 12:11 AM

Thanks Rimmer :thumbsup:

But no go. I closed IE and did a re-start

It is time for bed. I will shutdown and see what happens in the morning.

Hmm.. I wonder if I would set the default under View Source Editor
to C:\Windows\NOTEPAD.EXE
If that would make a difference...
Posted Image

#14 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:12:58 AM

Posted 04 January 2006 - 12:16 AM

That's a pity. :thumbsup:

In the morning, double check the path to that new key is right e.g.
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Internet Explorer \ View Source Editor \ Editor Name

If it is then it looks like that fix is no good.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#15 Scarlett

Scarlett

    Bleeping Diva

  • Topic Starter

  • Members
  • 7,479 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:As always I'm beside myself ;)
  • Local time:09:58 AM

Posted 04 January 2006 - 07:33 AM

That's a pity. :thumbsup:

In the morning, double check the path to that new key is right e.g.
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Internet Explorer \ View Source Editor \ Editor Name

If it is then it looks like that fix is no good.


Well I did and it is right where it is supposed to be. And all I get even after a re-boot is the notepad folder opens. No viewing of page source for me. :flowers:



Thanks for everything Rimmer. :trumpet:
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users