Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Limited Connectivity


  • Please log in to reply
1 reply to this topic

#1 dangerlight

dangerlight

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:10 AM

Posted 08 May 2011 - 06:25 PM

Okay, I know we've all juggled this problem time and time again, but it's got me stumped this time.

I was in the process of fixing and cleaning a friend's machine of viruses and the XP Antivirus 2011 malware, which had disabled their computer and its connectivity.

I succesfully stripped the machine of all its malicious software and re-enabled the onboard NIC card, but I simply get Limited or No Connectivity. I've tried every trick I know of, and even some I'd researched, and I'm at the end of my rope so let's throw it to you guys and see if you've got an idea... Desktop is connected directly to the cable modem, no router.

Microsoft Windows XP vers 2002
Service Pack 3

From ipconfig /all:

DHCP Enabled: Yes
Autoconfig Enabled: Yes
Autoconfig IP address: 169.254.142.4 (Obvious problem)
Subnet Mask: 255.255.0.0
Default Gateway:
(No DNS listed)

Device is listed as working in Hardware Manager.
In event log, I get a note for "Source - tcpip" that reads "The system detected that the network adapter Broadcom 440x 10/100 Integrated Controller was connected to the network, and has initiated normal operation over the network adapter." and one for "Dhcp - Your computer has automatically configured the IP address for the Network Card with network address 000D5656E19D. The IP address being used is 169.254.142.4"

I've tried a /release and /renew and it doesn't seem to be able to renew. I've disabled and re-enabled. I've uninstalled, and reinstalled the device also, to no avail. I've tried running WinsockxpFix. Per someone's suggestion, I tried:
netsh winsock reset catalog
netsh int ip reset c:\resetlog.txt
in a command prompt. This had no effect, on reboot.

The modem and cable are fine, as I've simply plugged the same cable into this laptop for the purposes of posting this; it works fine while plugged in here, siply not the other machine. Does anyone have any other software ideas, or do we think the onboard NIC went bad on me?

I appreciate the help, and any suggestions or follow-up troubleshooting would be much appreciated!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,391 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:08:10 AM

Posted 08 May 2011 - 08:22 PM

Worth reading, http://www.click2web.com/169.php .

http://www.ehow.com/how_5963613_change-169-ip-address.html

And, yes...the possibility of hardware failure always is there. In the case of a NIC, such is easily/cheaply overcome.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users