Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Virtual XP Mode Unknown Device


  • Please log in to reply
3 replies to this topic

#1 fleamour

fleamour

  • Members
  • 297 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:11:09 PM

Posted 28 April 2011 - 03:13 AM

I am running XP mode virtually under 7 & have yellow exclamation marked "Other devices" "Virtual PC Integration Device" showing in device manager. Could this be my graphics card?

Edited by hamluis, 28 April 2011 - 08:56 AM.
Moved from XP forum to Win 7.

ASRock Conroe (micro ATX) - Ubuntu 12.04/Win 7 Ultimate (x86)
Intel C2D E8400 3.0GHz/low profile Noctua (single fan)
4GB OCZ DDR2 RAM, GeForce GT220 1024MB

Vintage IBM-T21 laptop, Xubuntu Lucid LTS
512MB KingSpec RAM, 1GHz CPU [T22 Fan], Wireless-G PCMCIA, 7200RPM HDD

BC AdBot (Login to Remove)

 


#2 Union_Thug

Union_Thug

    Bleeps with the fishes...


  • Members
  • 2,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is everything
  • Local time:06:09 PM

Posted 28 April 2011 - 05:19 AM

Credit Kari @ Sevenforums for the following (Reply #3): http://www.sevenforums.com/virtualization/87349-virtual-pc-integration-device-missing.html

>>It is completely normal, not a problem. There are no drivers to this Virtual PC Integration Device.

When you boot a Virtual PC machine, your host (Windows 7) thinks you are creating a Remote Desktop Connection. Some really confusing terminology: You use a Client computer (host machine, Windows 7) to connect to a remote Host computer (virtual guest machine, XP Mode). For these two computers / machines to be able to communicate, Windows creates a so called VPC Bus (Virtual PC Host Bus Service) between the two computers, in your case between the Windows 7 and XP Mode.

Each time these buses are created, they can be seen in virtual machine's Device Manager. They need to be there, but because they are not device drivers per se, you'll see the exclamation marks. Let them just stay there, don't try to remove and / or disable them.

If you right click one of these Virtual PC Integration Devices and choose Properties from context menu, you will see that the Device Status is "This device is working properly".

More about remote Desktop Connection: open the Windows Help & Support, type Remote Desktop to search field and hit Enter. Choose Remote Desktop Connection: frequently asked questions. <<


#3 fleamour

fleamour
  • Topic Starter

  • Members
  • 297 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:11:09 PM

Posted 28 April 2011 - 05:36 AM

Hey thanks.
ASRock Conroe (micro ATX) - Ubuntu 12.04/Win 7 Ultimate (x86)
Intel C2D E8400 3.0GHz/low profile Noctua (single fan)
4GB OCZ DDR2 RAM, GeForce GT220 1024MB

Vintage IBM-T21 laptop, Xubuntu Lucid LTS
512MB KingSpec RAM, 1GHz CPU [T22 Fan], Wireless-G PCMCIA, 7200RPM HDD

#4 Union_Thug

Union_Thug

    Bleeps with the fishes...


  • Members
  • 2,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is everything
  • Local time:06:09 PM

Posted 28 April 2011 - 05:20 PM

You're welcome.:thumbsup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users