Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft .NET Framework 3.5 Install failed


  • Please log in to reply
3 replies to this topic

#1 Robert J

Robert J

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:53 PM

Posted 25 April 2011 - 06:02 AM

First let me say that if I posted this in the wrong forum, I apologize. Just new to this

Computer: Dell Optiplex GX270
CPU: Intel Pentium 4 CPU 3.00GHz
Op System: Windows XP Home SP3 5.1.2600(Retail)
Total Mem: 2GB
HDD: 40G internal, 80G External

I've spent the last 2 days trying to update the .NET Framework from 2.0 to 3.5. I have tried everything in this Microsoft article http://support.microsoft.com/kb/2438651#reso2

I still can't get the .NET framework to update. It downloads but won't install. I'm having other problems that I believe are caused by this same problem but I need to resolve this before I worry about anything else.

I have done a Windows repair from the XP home CD (Retail Version). I didn't use the console. At setup I clicked on the R to repair Windows. I have tried so many things that I can't remember all of them. I also tried to uninstall .NET Framework 2.0 Service Pack 2 using the add remove programs and receive the following message: Microsoft .NET framework 2.0 Service Pack 2 cannot be uninstalled because it will affect other applications that are installed. For more information, see http://go.microsoft.com/fwlink/?LinkId=91126 I've tried everything on that page as well. I tried to reinstall 2.0 again from a stand alone copy from Microsoft and got the following message:
Setup cannot continue because this version of the .NET Framework is incompatible with a previously installed one. For more information, see http://support.microsoft.com/support/kb/articles/q312/5/00.asp

I rebooted into Safe Mode and tried to remove 2.0 from there but couldn't remove it because I was in Safe Mode.

This is an entry I copied from the WindowsUpdate.log :2011-04-25 03:06:45:609 1128 1a4 Report REPORT EVENT: {0CE71B22-28E7-402F-856B-61249854F17B} 2011-04-25 03:06:40:609-0400 1 182 101 {4D6E7C9C-99BA-4448-8A0A-3E8E7B84D2FA} 104 80070643 MicrosoftUpdate Failure Content Install Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86.


I did the following as instructed by Microsoft web site:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"Logging"="voicewarmupx"
"Debug"=dword:00000007
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
"Flags"=dword:00000016
"Level"=dword:00000004

This is the newest error:
2011-04-25 01:01:01:875-0400 1 182 101 {4D6E7C9C-99BA-4448-8A0A-3E8E7B84D2FA} 104 80070643 MicrosoftUpdate Failure Content Install Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86.

I was able to install .NET Framework 4 but updates still require 3.5 which always gives me a fatal error and refuses to install.

The only thing I haven't done so far is delete partition, format and reload. At this point, that isn't an option

I've gone in circles for 2 days and my brain is mush. If anyone can help with this quandary I would really appreciate it. If you need any other info, please just let me know

Attached Files



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,388 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:53 PM

Posted 25 April 2011 - 09:58 AM

If you have 4.0 installed, what's the reason for now installing 3.5, SP1?

Frankly, I have 3.5, SP1 and 4.0 both installed on this system, with no problems...while I have installed 3.5, SP1 on my other system.

I suggest uninstalling all versions currently on your system, using the tool located at http://cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog_Tools/dotnetfx_cleanup_tool.zip .

Then I would install 3.5, SP1.

Louis

#3 Robert J

Robert J
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:53 PM

Posted 27 April 2011 - 12:24 AM

Forum Addict

First, let me thank you for taking the time to read this and respond.

Came to the conclusion that 4 was messed up also. I did solve the problem though. Repartitioned, formatted and reloaded XP lol To many problems with last install. No idea why but this one I did and the old girl is working just fine now. I did try the tool but it didn't work. That's when I called the owner and got the CD key and redid the XP.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,388 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:53 PM

Posted 27 April 2011 - 06:41 AM

Your resolution is one I often use with unknown problems :), glad you were able to resolve it.

Happy computing :).

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users