Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't remove write protection or corrupt files from thumb drive


  • Please log in to reply
1 reply to this topic

#1 frank11111

frank11111

  • Members
  • 61 posts
  • OFFLINE
  •  
  • Local time:06:03 PM

Posted 25 April 2011 - 02:28 AM

I'm running 32 bit Microsoft XP Home, SP3
The Thumb is a 32gb Kingston DataTraveler


An AVI file was somehow corrupted when I moved it to my thumb drive. Whenever I tried to delete it, I just got an alert that it was corrupt and unreadable (I can't remember the exact error) and then my computer would freeze and I would have to hard restart.
The thumb is in FAT32 format so the hard restart is what I think caused further problems. When it reboots, my computer runs a check disk on the thumb drive "for consistency" and reports that the AVI is corrupt. I tried to reformat the thumb which just caused a crash and now when I try to modify its contents or name it says it can't because it's write protected.

Things I've tried:


Found quick tutorial on how to modify registry value to disable write protection. I had to create the folder "StorageDevicePolicies" Under HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>, then clicked on WriteProtect and set the value from 1 to 0. I clicked on a download in the tutorial that installed the folder. This worked but I was still unable to deal with the corrupt files. I tried to reformat again, it crashed, and now it is write protected again and changing the registry value doesn't help.

I included a screen cap of the StorageDevicePolicies folder contents, so if you know what you're doing please take a look at it.

After that I tried setting the value to 1 while the tumb was connected, ejecting the thumb, restarting, connecting the thumb, resetting to 0, ejecting and restarting. Upon restart I still can't write.

I have tried using Delete Doctor and Unlocker to eliminate the corrupt file which don't work due to write protection. Although I may have tried delete Doctor to no avail even before the write protection problem.

I tried deleting the file in safe mode before the write protection problem and the file disappeared from the thumb only to return upon restart.

Scanned thumb for virus with SUPERAntiSpyware

Tried to eliminate the file in safe mode using unlocker despite write protection.


Other Info:


I'm not having any virus problems I can detect after extensive scanning, and my computer is stable in every other way. Messing with the registry has not caused any detectable problems. My other thumb drive is working fine and so is the original copy of the AVI

Attached Files


Edited by hamluis, 25 April 2011 - 10:07 AM.
Moved from XP to External Hardware.


BC AdBot (Login to Remove)

 


#2 frank11111

frank11111
  • Topic Starter

  • Members
  • 61 posts
  • OFFLINE
  •  
  • Local time:06:03 PM

Posted 25 April 2011 - 10:04 AM

Is it possible to move this to a different forum? The external hardware forum is probably more appropriate




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users