Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error loading strange .dll on start-up + re-directs


  • Please log in to reply
12 replies to this topic

#1 Rez13

Rez13

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 20 April 2011 - 12:18 PM

Hello, I'm sorry to make my first post here a request for help, but I've exhausted my limited knowledge, and nothing seems to be working.

I'm running Windows Vista 32bit with all recent updates EXCEPT Service pack 2 (leery of installing it), along with Malware Bytes - again all recent updates, and AVG 2010 with all recent updates.

Last night AVG reported a Cryptiq trojan stopped. I googled it and found a thread on here of someone reporting similar symptoms to what I've been experiencing for a while, namely, browser re-directs from Google searches. Neither Malwarebytes nore AVG report anything after a scan, though I haven't run them in Safe Mode yet.

This morning, after thinking everything was fine because AVG said it stopped the trojan, I got a message on start-up that read:

"Error loading
C:\\Users\Reston\AppData\Local\smiWebTime\SyncHelpInit.dll

The specified module could not be found."

I restarted, not sure if it was just an odd error, but the same message appeared. (my username is Reston, there are no other users on this computer)

Another symptom I should mention (though I've always felt it was hardware-related) is that every once in a while, my screen with turn into what you might call a "swatch patter" - diagonal lines consisting of the main colours that were on the screen before it happened. It will stay there, and only shutting down via the power button ever does anything. I'm on an Acer Aspire laptop, which I've heard are infamous for over heating, and since after this "swatch pattern" appears, it usually takes a few minutes before my computer will start again (it will normally begin start-up, then shut off) I've always thought it was some kind of over heating problem, or a video card over heating problem. But I'm well aware I know very little about computers, so may be totally misinterpreting this.

If any of these symptoms sound like a virus, malware, trojan, or anything that's slipped through, can anyone please help me? I'm sorry if this is in the wrong place or if I've left out any important information, please let me know.

Thank you for taking the time to read this.


Edit: I've read through some similar posts to mine on this site, and I apologize for posting such a common problem, but I don't want to assume I know what to do just from reading other fixes.

Edited by Rez13, 20 April 2011 - 01:00 PM.


BC AdBot (Login to Remove)

 


#2 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:05:29 AM

Posted 20 April 2011 - 09:11 PM

Hello and welcome.
Its not unusual to receive such an error after using specialized fix tools.

A "Cannot find...", "Could not run...", "Error loading... or "specific module could not be found" message is usually related to malware that was set to run at startup but has been deleted. Windows is trying to load this file but cannot locate it since the file was mostly likely removed during an anti-virus or anti-malware scan. However, an associated orphaned registry entry remains and is telling Windows to load the file when you boot up. Since the file no longer exists, Windows will display an error message. You need to remove this registry entry so Windows stops searching for the file when it loads.

To resolve this, download Autoruns, search for the related entry and then delete it.

Create a new folder on your hard drive called AutoRuns (C:\AutoRuns) and extract (unzip) the file there. (click here if you're not sure how to do this.)
Open the folder and double-click on autoruns.exe to launch it.
Please be patient as it scans and populates the entries.
When done scanning, it will say Ready at the bottom.
Scroll through the list and look for a startup entry related to the file(s) in the error message.
Right-click on the entry and choose delete.
Reboot your computer and see if the startup error returns.



Please download the TDSS Rootkit Removing Tool (TDSSKiller.exe) and save it to your Desktop. <-Important!!!
Be sure to download TDSSKiller.exe (v2.4.0.0) from Kaspersky's website and not TDSSKiller.zip which appears to be an older version 2.3.2.2 of the tool.
  • Double-click on TDSSKiller.exe to run the tool for known TDSS variants.
    Vista/Windows 7 users right-click and select Run As Administrator.
  • If TDSSKiller does not run, try renaming it.
  • To do this, right-click on TDSSKiller.exe, select Rename and give it a random name with the .com file extension (i.e. 123abc.com). If you do not see the file extension, please refer to How to change the file extension.
  • Click the Start Scan button.
  • Do not use the computer during the scan
  • If the scan completes with nothing found, click Close to exit.
  • If malicious objects are found, they will show in the Scan results - Select action for found objects and offer three options.
  • Ensure Cure (default) is selected, then click Continue > Reboot now to finish the cleaning process.
  • A log file named TDSSKiller_version_date_time_log.txt (i.e. TDSSKiller.2.4.0.0_27.07.2010_09.o7.26_log.txt) will be created and saved to the root directory (usually Local Disk C:).
  • Copy and paste the contents of that file in your next reply.


Rerun MBAM (MalwareBytes) like this:

Open MBAM in normal mode and click Update tab, select Check for Updates,when done
click Scanner tab,select Quick scan and scan (normal mode).
After scan click Remove Selected, Post new scan log and Reboot into normal mode.

Please ask any needed questions,post 2 logs and Let us know how the PC is running now.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#3 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 20 April 2011 - 09:39 PM

Thank you so much for taking the time to answer.

I found the startup entry in AutoRuns, and the run .dll error did not persist after start-up. (yaaay one problem down)

When I ran TDSSKiller.exe, it came back with the following, and I took no action, choosing "Skip" over "Confine to quarantine" or "Delete"

Posted Image

Uploaded with ImageShack.us

After that, it said no malicious items were found, and there was no log file to copy.

I have no yet run MBAM, as I would like to know what to do about that locked file. Is it something that should be there?

#4 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:05:29 AM

Posted 20 April 2011 - 09:52 PM

Ok,that is a skip.. move on to MBAM.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#5 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 20 April 2011 - 10:13 PM

MBAM Quick scan log:


Malwarebytes' Anti-Malware 1.46
www.malwarebytes.org

Database version: 6410

Windows 6.0.6001 Service Pack 1
Internet Explorer 7.0.6001.18000

20/04/2011 11:07:45 PM
mbam-log-2011-04-20 (23-07-45).txt

Scan type: Quick scan
Objects scanned: 154577
Time elapsed: 9 minute(s), 36 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)


My system actually seems a little faster since deleting the errant startup entry, but I can't unfortunately say anything to the redirects or random shut downs/diagonal "swatch pattern" as they're unpredictable. I can however add that earlier, before getting your response, I tried to run MBAM in Safe mode, and left it to it, knowing MBAM usually takes 1hr and 40min, and came back to find my computer shut off. I restarted in safe mode, it said it had shut down incorrectly but I continued anyway, and tried MBAM again, but my comupter shut off again, at around 50min into the scan. As I mentioned before, I believe I'm having hardware issues (machine is 3 years old) but I don't know enough to say that for sure and didn't want to leave this possible symptom out.

Thank you again for all your help so far. May I ask why the suspicious item in TDSSKiller was a skip? I'm just curious. :P

Edited by Rez13, 20 April 2011 - 10:16 PM.


#6 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:05:29 AM

Posted 20 April 2011 - 10:24 PM

Your MBAM need an update its at 1.50,you show Malwarebytes' Anti-Malware 1.46


Rerun MBAM (MalwareBytes) like this:

Open MBAM in normal mode and click Update tab, select Check for Updates,when done
click Scanner tab,select Quick scan and scan (normal mode).
After scan click Remove Selected, Post new scan log and Reboot into normal mode.

Please ask any needed questions,post logs and Let us know how the PC is running now.

I have to leave,will lok back.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#7 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 20 April 2011 - 10:33 PM

I did follow your instructions for updating, though. I guess I'll try again.

Thanks again.

Edited by Rez13, 20 April 2011 - 10:53 PM.


#8 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 20 April 2011 - 10:54 PM

The new log:


Malwarebytes' Anti-Malware 1.50.1.1100
www.malwarebytes.org

Database version: 6410

Windows 6.0.6001 Service Pack 1
Internet Explorer 7.0.6001.18000

20/04/2011 11:51:12 PM
mbam-log-2011-04-20 (23-51-12).txt

Scan type: Quick scan
Objects scanned: 153644
Time elapsed: 8 minute(s), 20 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)



Apologies for wasting time with the first, out-of-date one.


Update: I preformed several searches trying to replicate the re-direct issue. Oddly enough it shows up when searching for recipes, among other things, and so far, tonight anyway, it hasn't reared its head.

Edited by Rez13, 20 April 2011 - 11:01 PM.


#9 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:05:29 AM

Posted 21 April 2011 - 09:06 AM

Let me know if it's still OK after a day.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#10 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 21 April 2011 - 09:07 AM

Will do. Thank you so much for all your help!

#11 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 22 April 2011 - 12:54 PM

The .dll error has remained gone, and strangely the re-directs seem gone as well. Thank you so much!

#12 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:05:29 AM

Posted 22 April 2011 - 04:59 PM

Great!! You're welcome.
If there are no more problems or signs of infection, you should Create a New Restore Point to prevent possible reinfection from an old one. Some of the malware you picked up could have been saved in System Restore. Since this is a protected directory your tools cannot access to delete these files, they sometimes can reinfect your system if you accidentally use an old restore point. Setting a new restore point AFTER cleaning your system will help prevent this and enable your computer to "roll-back" to a clean working state.

The easiest and safest way to do this is:
  • Go to Start > Programs > Accessories > System Tools and click "System Restore".
  • Choose the radio button marked "Create a Restore Point" on the first screen then click "Next". Give the R.P. a name, then click "Create". The new point will be stamped with the current date and time. Keep a log of this so you can find it easily should you need to use System Restore.
  • Then use Disk Cleanup to remove all but the most recently created Restore Point.
  • Go to Start > Run and type: Cleanmgr
  • Click "Ok". Disk Cleanup will scan your files for several minutes, then open.
  • Click the "More Options" tab, then click the "Clean up" button under System Restore.
  • Click Ok. You will be prompted with "Are you sure you want to delete all but the most recent restore point?"
  • Click Yes, then click Ok.
  • Click Yes again when prompted with "Are you sure you want to perform these actions?"
  • Disk Cleanup will remove the files and close automatically.
Vista Users can refer to these links: Create a New Restore Point and Disk Cleanup.

Tips to protect yourself against malware and reduce the potential for re-infection:Avoid gaming sites, pirated software, cracking tools, keygens, and peer-to-peer (P2P) file sharing programs. They are a security risk which can make your computer susceptible to a smörgåsbord of malware infections, remote attacks, exposure of personal information, and identity theft. Many malicious worms and Trojans spread across P2P file sharing networks, gaming and underground sites. Users visiting such pages may see innocuous-looking banner ads containing code which can trigger pop-up ads and malicious Flash ads that install viruses, Trojans and spyware. Ads are a target for hackers because they offer a stealthy way to distribute malware to a wide range of Internet users. The best way to reduce the risk of infection is to avoid these types of web sites and not use any P2P applications. Read P2P Software User Advisories and Risks of File-Sharing Technology.

Keeping Autorun enabled on USB and other removable drives has become a significant security risk due to the increasing number of malware variants that can infect them and transfer the infection to your computer. To learn more about this risk, please read:
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#13 Rez13

Rez13
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 AM

Posted 22 April 2011 - 05:47 PM

Ah, brilliant. I'll do that tonight. I had some Windows updates today so there is a nice fresh restore point already. :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users