Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Autorun suddenly stopped working after manually changing settings


  • Please log in to reply
13 replies to this topic

#1 lti

lti

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 17 April 2011 - 04:23 PM

I tried to change the Autoplay setting for my flash drive to automatically open an Explorer window thenever the drive is connected, and now Autoplay does not work at all. I changed this setting by opening the Properties window for the flash drive, switching to the AutoPlay tab, choosing "Mixed content" from the menu, and selecting the "Open folder to view files" option. I want to get Autoplay/Autorun working on this computer so I do not have to manually play audio CDs and DVD movies. Having the flash drive open automatically is not a concern for me anymore. I am using Windows XP Home Edition SP3, fully updated. Thanks for any help.

Edited by lti, 17 April 2011 - 04:24 PM.


BC AdBot (Login to Remove)

 


#2 pip22

pip22

  • Banned
  • 341 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:51 PM

Posted 18 April 2011 - 10:05 AM

http://www.real-knowledge.com/autoplay.htm

#3 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 18 April 2011 - 05:10 PM

Changing those settings did not change anything (those settings were actually what caused the problem), but I did see a Restore Defaults button. I'll try that next.

Edited by lti, 18 April 2011 - 05:28 PM.


#4 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 18 April 2011 - 05:31 PM

Restoring the default settings did not work.

#5 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:51 AM

Posted 19 April 2011 - 12:54 AM

Have a look at the following Microsoft Support article:
How to disable the Autorun functionality in Windows

You can enable as well as disable ... using this info: "To disable or enable Autorun automatically, click the appropriate Fix this problem link."

There is a "Fix it for me" option which I suggest you use as the safest way to do the job.


If the above fix from Microsoft does not work, please let us know and we will continue from there and have a look at the relevant registry keys.

FYI a similar issue was resolved in the following topic: http://www.bleepingcomputer.com/forums/topic376350.html
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#6 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 19 April 2011 - 07:19 PM

Microsoft's fix did not work, but the fix in the topic you linked to partially worked. A flash drive still will not open automatically (which is good for security reasons), but an audio CD was detected and the Autoplay window appeared. When I chose to play the disc in Windows Media Player, the disc appeared to play, but no sound was heard. I tried again and the sound played but stuttered. A DVD movie did the same thing, except both the video and sound stutter and the CPU usage is stuck at 100% while the disc is playing. I did not have any of these problems before the autorun fix.

Edited by lti, 19 April 2011 - 07:20 PM.


#7 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:51 AM

Posted 19 April 2011 - 10:33 PM

I would like to have a look at the relevant entries in the Windows registry.

:step1: Please export to text files, the contents of two registry keys:
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg1.txt "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg2.txt "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK

:step2: Please post the contents of the two exported registry keys for us to look at:
  • Double-click/Open My Computer and then navigate to C:\ drive
  • In there, you should see two files called reg1.txt and reg2.txt.
  • Double-click one of the files to open it with Notepad.
    • Copy and paste the whole contents of that file in your next reply.
  • Repeat with the second text file, to include the contents of that file also in the same reply.

Edited by AustrAlien, 19 April 2011 - 10:34 PM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#8 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 20 April 2011 - 06:36 PM

reg1.txt:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"AllowLegacyWebView"=dword:00000001
"AllowUnhashedWebView"=dword:00000001
"HonorAutoRunSetting"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\Run]


reg2.txt:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer\run]

I'm not sure how removing the entry that the other thread said to remove caused CDs and DVDs to stutter and require very high CPU usage to play.

#9 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:51 AM

Posted 20 April 2011 - 07:36 PM

I'm not sure how removing the entry that the other thread said to remove caused CDs and DVDs to ... require very high CPU usage to play.

Me neither: I can think of no reason for there to be any relationship between the two matters.

Please check how your system copes with playing CDs and DVDs again. Try manually starting them, as well as launching using Autorun. Any difference? Are you still experiencing the 100% CPU usage problem?

If the problem of high/100% CPU usage persists, open Task Manager and under the Processes tab, determine what process is consuming the majority of CPU resources at the time you try playing CDs and DVDs. Let me know what you see.

Edit: A quick look at your two registry exports, and I think they are quite OK.

Edited by AustrAlien, 20 April 2011 - 07:37 PM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#10 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 20 April 2011 - 08:23 PM

When playing a CD, CPU usage stays around 30%, most of which is used by wmplayer.exe. When playing a DVD, taskmgr.exe uses 10-20% CPU usage, while wmplayer.exe takes up the last 80-90%. It is strange that Task Manager has such high CPU usage only while playing a DVD. At all other times, the CPU usage of taskmgr.exe is only 1-3%. I closed Task Manager and the DVD did not play any better. I tried a second DVD and the CPU usage stayed within a normal range (70-90% for this computer), but taskmgr.exe still had unusually high CPU usage and the sound and video still stuttered.

Also, even though I chose to play the disc in InterVideo WinDVD in the autoplay window, the disc played in Windows Media Player instead. In either program, the CPU usage remains the same.

#11 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:51 AM

Posted 21 April 2011 - 11:35 AM

... even though I chose to play the disc in InterVideo WinDVD in the autoplay window, the disc played in Windows Media Player instead.

That's a strange one.


When playing a CD, CPU usage stays around 30%, most of which is used by wmplayer.exe.

So, are audio CDs playing normally now?

Ignoring autorun/autoplay for USB drives, I take it that autorun/autoplay is now working as it should for your optical drive(s).

The issue of high CPU usage when playing DVDs is going to require more investigation: I suggest that since the autorun matter is resolved, you make a new topic dedicated to the DVD issue.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#12 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 21 April 2011 - 05:12 PM

No, CDs still do not play normally. I'll post a separate thread for those two problems.

#13 lti

lti
  • Topic Starter

  • Members
  • 594 posts
  • OFFLINE
  •  
  • Local time:09:51 AM

Posted 23 April 2011 - 02:22 PM

The sound problem has been fixed. Here is the thread I posted about this problem. The only thing I could see causing the optical drive to suddenly switch to PIO Only mode was Microsoft's Fix It tool.

#14 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:51 AM

Posted 23 April 2011 - 04:53 PM

Good job: Broni was right on to that one!

Thank you for letting me know.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users