Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Problems with Floppy Disk Drive - USB and Internal

  • Please log in to reply
1 reply to this topic

#1 csingsaas


  • Members
  • 3 posts
  • Local time:07:13 AM

Posted 15 April 2011 - 09:26 AM

We have a Dell Dimension 5150 (Windows XP Pro) - recently the hard drive went out and I had to put in a new one and do a reinstall of the OS. Everything installed perfectly - except the floppy drive showed up in device manager as detected - but not functioning properly (icon that looks like a yellow circle with an exclamation mark in it). I got on the horn with Dell and they said the floppy drive needed to be replaced. They shipped me a new internal floppy drive which I swapped out - but the same thing happened. It is detected under device manager (with the yellow circle icon) but not functioning. There is no A: drive under my computer.

We tried many things to troubleshoot - uninstalling and reinstalling drivers, disabling the drive in BIOS and reenabling them, updating BIOS, and whatever else.

I then ordered a USB floppy disk drive - plugged it in, and the same exact thing happens. A message pops-up on the screen when you initially plug it in that new hardware has been detected. It then tries to install a driver or something - but then pops-up a message stating that there was an error while trying to install the hardware. Like the internal floppy drive, it does show up under device manager with the yellow circle/exclamation mark.

I verified the USB floppy works on other computers without issue. I also verified that the USB port I was plugging it into works with other devices.

I guess the conclusion is to either reinstall the OS (Which I did before the problem started) or possibly a motherboard problem. I'm not at all excited about reinstalling the OS with no guarantee it will be fixed.

Any other recommendations to get this fixed?

If not, are there any USB floppy drives out there that do not use Windows native drivers? I'm thinking if I can use some sort of floppy drive that relies on it's on manufacturer made drivers, than I can skirt the issue. Do Iomega floppy drives use windows native drivers or do they use their own set of proprietary drivers?

All this for a floppy drive! *sigh*

BC AdBot (Login to Remove)


#2 Particalzman


  • Members
  • 51 posts
  • Gender:Male
  • Local time:06:13 AM

Posted 15 April 2011 - 01:08 PM

Don't know if you tried it already but you can go to dell. com then I think download drivers enter your model number and then you can choose all the correct drivers for your system. With the problems your having you may have to copy them to cd-rw. It should just be a driver problem, you might power it down and double check all your connections are good.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users