Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Explorer.exe - Application Error


  • Please log in to reply
6 replies to this topic

#1 Abrahmm

Abrahmm

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:09:58 PM

Posted 30 December 2005 - 02:27 AM

Hello everyone. I am using Windows XP Home Edition. Before today, my computer ran perfectly and rarely crashed. Well today I installed a game I bought(Knights of the Old Republic if it matters) and began playing it. The game crashed on me a couple times, and my computer completely froze up when I tried to minimize the game. When I restarted the computer, my backround didn't cover the whole screen, and over the backround was a black backround with text saying something about my computer being infected, but I couldn't read it because of the icons on the desktop. Then a window of a virus scanner I had never heard of popped up telling me I had 10 infected files. I thought it was some pop up ad and closed it. My computer froze again shortly after and I restarted it again.

During the restart, I received an error message while Windows was loading(I don't choose a user, there is only 1 so it goes to that by default) saying "Explorer.EXE - Application Error: The application failed to initialize properly(0xc0000005). Click on OK to terminate the application" so I clicked ok and it loaded up the backround of my desktop and that is it. No taskbar or icons. So I restarted my computer again, and again I got the same message, with the same result. I am able to start programs through the Task Manager, but Explorer won't start and I get the same message. I installed McAfee Virus Scan Professional(2005 version) and ran a virus scan which showed no virus'. I have been messing with stuff all night through msconfig. I am able to boot up in Safe Mode and access files that way. I uninstalled the game but it didn't help.

Can somebody please help? I appreciate anything anyone can offer. I just hope I don't have to use the re-format CD(Which I don't have with me). Thanks in advanced.

Edited by Abrahmm, 30 December 2005 - 02:28 AM.


BC AdBot (Login to Remove)

 


m

#2 merlo

merlo

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:58 PM

Posted 30 December 2005 - 06:22 AM

Sounds like a some visiouse malware on your system...
try downloading and installing microsoft antispyware beta.
Mcafee wont pick them up but the microsoft spyware seems to get
rid of nasty browser jokers.
Keep me posted

#3 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:08:58 PM

Posted 30 December 2005 - 06:58 AM

Are you using these basic security programs?
(They're all free.)
aČ free
ewido security suite
Ad-Aware
Spybot S&D

These 2, will help prevent spyware/malware from being installed in the first place:
Spywareblaster
SpywareGuard

Download them, update them, and then run them.
These programs, updated and used regularly, will do a lot to keep your computer clean of spyware, trojans, keyloggers, browser hijackers, etc...

When installing ewido security suite, under Additional Options uncheck:
Install background guard
Install scan via context menu

Important:
Please read this tutorial on Spybot S&D before using it. Spybot can do SERIOUS damage, if not used properly.

Helpful Tutorials:
Using Ad-Aware SE
Using SpywareBlaster
Using SpywareGuard
Using Ewido

If the above doesn't help rid you of the problem, then:

Read How to post a HijackThis Log.
Please read, and follow, all directions carefully.

Then, run a log, and post it in the HijackThis forum, at this link. Do not, fix anything, yet.
A member, of the HJT Team, will help you out.
It may take a while to get a response, because the HJT Team are very busy. Please, be patient, these people are volunteers. They will help you out, as soon as possible.

NOTE:
Once you have made the post, please, DO NOT make another post in the HJT forum, until it has been responded to by a member of the HJT Team. The first thing they look for, when looking for logs to reply to, is 0 replies. If you make another post, there will be 1 reply. The team member, glancing over the replies, might assume someone is already helping you out, and will not respond. So, just make your post, and let it sit there, until a team member responds. This way you will be taken care of, in the most timely manner.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#4 Abrahmm

Abrahmm
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:09:58 PM

Posted 30 December 2005 - 08:04 PM

Thanks for the help. I downloaded Ad-Aware SE and Spybot S&D, and ran scans on both. Ad-Aware gave me 6 spyware and Spybot S&D gave me 3. After clearing these out of my system I still recieve the same error message. I then downloaded HijackThis, but when I unzip it I get a notice from McAfee saying that it has detected a virus, and I am not able to open hijack this. If I scan the HijackThis folder with McAfee it tells me there is a worm in it. Is this normal? Thanks for the help

#5 Abrahmm

Abrahmm
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:09:58 PM

Posted 31 December 2005 - 03:22 PM

I've also found that my sound isn't working. I tried running a game on the computer and I got a notice before it started saying that my sound card was missing or disabled, and it asked if I wanted to continue without sound. Anybody know what could cause this? Thank you for the help

#6 -David-

-David-

  • Members
  • 10,603 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London
  • Local time:03:58 AM

Posted 31 December 2005 - 05:56 PM

Hi there, this should get rid of the error.

Go to start > run and copy and paste next line in the field:

regedit /a C:\backupkey.reg HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RPCKDM

Then open notepad and and copy and paste next bold in it:
(don't forget to copy and paste REGEDIT4)

REGEDIT4

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RPCKDM]


Save this as "fix.reg" Choose to save as *all files and place it on your desktop.

It should look like this: Posted Image

Doubleclick on it and when it asks you if you want to merge the contents to the registry, click yes/ok.

Reboot and open your Internet Explorer.
Post a new hijackthislog in your next post.

David

#7 Abrahmm

Abrahmm
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:09:58 PM

Posted 02 January 2006 - 03:47 AM

Ok, I did this, but it did not work the way you described. Is something suppose to happen when I copy and paste the first line into Run? Nothing happens. When I save that notepad as "All files", it shows up with the icon of a file with no program to run it, and when I double click on it, it asks me what program I want to run it with. Thanks for the help




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users