Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Google & Bing search result links redirected to junk sites


  • Please log in to reply
1 reply to this topic

#1 lunarpod

lunarpod

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:12:53 PM

Posted 13 April 2011 - 08:30 AM

Hi,
This is my first post here but I have been on the site before to get help by browsing other members posts & advice. I now, for the first time, am so stuck on what to do to solve this problem that I'm requesting some help myself. PLEASE HELP!!
The problem is that in both Firefox & Internet explorer (I haven't tried other browsers) the results of any search in either Google or Bing are being redirected to junk/ad sites (mostly - but sometimes even ebay or youtube). I then have to click the Back button & clicking the link a second time then takes me to where it should do. This is most annoying!!
So far i have run Avira Antivirus & found nothing. SpyHunter finds nothing. MalwareBytes will only run in safe mode & finds nothing. ComboFix will only run in safemode & does not solve the issue. I have edited my Hosts file to remove a HUGE list of spam sites to leave only this entry: 127.0.0.1 localhost. Also, this may be unrelated but my copy of CopyToDVD stopped working around the same time this issue started. My PC just freezes when I try use this program & I need to switch off with the main power button. Again, this my be unrelated to the search links problem.
Anyway - any help anyone can give me will be greatly appreciated!
Thanks,
Paul.
I forgot to mention that very recently I had a big problem with getting loads of popups, very erratic PC behaviour & stuff disappearing from my Start Menu. Avira & Spyhunter resolved this but the Search Links being redirected is still ongoing.

I just installed Google Chrome & did a google search. The links are redirected just the same as in the other browsers.

I have now managed to run both Malwarebytes & Combofix whilst in normal windows mode (not safe mode). I did this by renaming the executable files to some random file name then double clicking on them. Malwarebytes found 3 trojans & a browser hijacker which it removed. Combofix detected some rootkit activity in Windows\system32\drivers\atapi.sys and presumably dealt with it accordingly. Maybe it was this that was causing CopyToDVD not to work? Anyway - I went back onto the internet to do a google search to see if I was redirected to a junk site and guess what? I was!! It is STILL flippin happening!! I am now gently but consistently banging my head against the wall whilst weeping into a cup. I shall use the cup of tears to wash down a bottle of paracetamol later...

Edited by lunarpod, 13 April 2011 - 03:08 PM.


BC AdBot (Login to Remove)

 


#2 lunarpod

lunarpod
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:12:53 PM

Posted 14 April 2011 - 12:56 PM

I am going to re-post with more information so please ignore this request.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users