Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trackball mouse not working on XP Pro


  • Please log in to reply
3 replies to this topic

#1 duffsparky

duffsparky

  • Members
  • 268 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:12 AM

Posted 01 April 2011 - 03:33 PM

Hi all from a newbie,

I have a PS2 Compaq MX-11800 combination keyboard with trackball mouse.

The keyboard/TB mouse work find on my HP xw6000 PC running XP Pro SP3 and will work OK in combination with a USB mouse (not that I want both).

When the keyboard/TB mouse are connected to my HP Pavilion t645.uk PC running XP Pro SP3, the trackball will not work, although it appears in device manager as a PS2 mouse without showing any issues.

On both PC's the resources and drivers appear to be the same and a separate standard PS2 mouse connected to the HP Pavillion works OK, so does a Microsoft PS2 trackball. I've checked the physical PS2 socket on the HP Pavillion and closed up the socket recepticals just in case, but still no joy.

I always do a full power down before connecting/disconnecting PS2 devices. I've tried the USB mouse through a Microsoft USB to PS2 adapter and 2 different PS2 to 9 pin serial adapters (one MS and one a.n.other) and none of them will work.

I don't have a specific driver CD for the device - it has always worked with the generic drivers that come with XP Pro SP1a, SP2 and SP3.

However, I've just realised the xw6000 PC operating system was built from (Hewlett Packard) XP Pro SP1a then updated with SP2 then SP3, whereas the t645 operating system was built from (Hewlett Packard) XP Pro SP1a and updated with SP3 only. I have read in odd places, now I come to think of it, that to update XP Pro SP1(a?) straight to SP3 can cause problems. But then again I've also read that this is complete 'eye wash' and as SP2 is no longer available from Microsoft I'd kind of lean towards the 'eye wash' camp.

I've done alot of searching on the net but so far without success, therefore, any suggestions or help would be much appreciated.

Cheers.

Edited by hamluis, 02 April 2011 - 09:04 AM.
Moved from XP to External Hardware.


BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:12 AM

Posted 01 April 2011 - 10:59 PM

Hi -
I read the other answer and it was a bit vague -
First have you attempted to use any other mouse , with or without success -
Next you could open Control Panel > System > Hardware > Device manager - Now look at the Mouse section > Click + to open it and see if any mouse is listed at all -
If there is , Double click on the listed mouse and click through the headings to see if any drivers are listed or under General to see if the box says This Device Is Working Properly -
You can go to Roll back Driver > Click on that > then Update Driver if there is still a problem -
If these instructions are not helpful you may need to spend $10 on a new mouse -

Thank You -

#3 duffsparky

duffsparky
  • Topic Starter

  • Members
  • 268 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:12 AM

Posted 02 April 2011 - 04:42 AM

Thanks for the reply noknojon,

I've already done the things you suggest.

I've tried a standard PS2 Microsoft, a Microsoft trackball mouse and a generic mouse all of which work ok.
I've tried to connect the MX-11800 mouse through a Microsoft PS2/USB adapter, a Microsoft PS2/Serial adapter and a generic PS2/Serial adapter with no luck.
The drivers and resources as seen through device manager all appear correct and are the same as the ones shown for the xw6000 PC with which the MX-11800 works.

The issue is not that I don't want to buy a new mouse, the mouse that I can't get working is an integral part of the MX-11800 keyboard and it is that layout I want.
Posted Image
Model MX11800
Type No., G80-11802LPAUS/03
FCC ID ; GDDG80-11801
Manufactured week/year; M26
MX/Brown/Tactile ( Ergonomic )
Straight cable with PS/2 and PS/2 mouse plug

#4 duffsparky

duffsparky
  • Topic Starter

  • Members
  • 268 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:12 AM

Posted 06 April 2011 - 12:38 PM

Solved the problem.
Either the mobo or trackball are working outside of their spec (volts and or current) or the spec of the two devices does not overlap enough (volts and or current). I've connected a powered PS2 range extender and the track ball now works, yippee.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users