Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Externl HDD Media Player Will Not Read G: Drive Dissapeared


  • Please log in to reply
No replies to this topic

#1 SCSI Needs Your Help

SCSI Needs Your Help

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Local time:07:36 AM

Posted 30 March 2011 - 04:28 PM

I hve a Cyclone HDD Multimedia player that up until yesterday worked perfectly.

I am running XP. It was attached via USB to a port G: and this has also dissapeared when I look in Computer Management/Disc Management it had gone.
The port is now coming up as K: when i plug another memory card in there with the USB lead, but the Cyclone is not bing read and it would nomally say "G:Cyclone" in My Computer.

When I plug the Multimedia player into any USB port I get the "Device Connect" Beep, when I plug it into another computer I get thsame beep.

In Device Manager it is coming up under Disk Drives as "USB Device".

When I plug in the Cyclone HDD Multimedia player with no computr connection ad power up the LED display says "Hello".

When I plug the device direct in to the television it comes up with the folders for Pictures Music Films but shows no content.

How can I get it working again?

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users