Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Getting message "The Pipe State is Invalid"


  • Please log in to reply
10 replies to this topic

#1 dteneyck

dteneyck

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 28 March 2011 - 06:47 PM

I keep getting the error message "The Pipe State is Invalid" every time I try to turn on my malware protection. I also get the message whenever I try to download certain software. I use AVG anti-virus free. Restarting the computer has not helped.
Another problem which may be related is that searches take a long time to start. I will type in one letter and the system freezes for a couple of minutes before it works. It is not using up the CPU during this time.

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,725 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:00 PM

Posted 28 March 2011 - 08:24 PM

every time I try to turn on my malware protection

Which malware protection would that be?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 dteneyck

dteneyck
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 28 March 2011 - 08:42 PM

every time I try to turn on my malware protection

Which malware protection would that be?

The one that comes with AVG.

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,725 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:00 PM

Posted 28 March 2011 - 09:39 PM

That error message may be caused by some AVG malfunction.
Uninstall AVG, using AVG Remover: http://www.avg.com/us-en/download-tools
Install fresh copy.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#5 dteneyck

dteneyck
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 30 March 2011 - 07:54 PM

I got the message "The Pipe State is Invalid" when I tried to download the software.
My wife tells me that she has gotten the same message when she tried to download some software that wasn't avg related.

What causes this message?

#6 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,725 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:00 PM

Posted 30 March 2011 - 09:36 PM

Did you try my previous advice?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#7 dteneyck

dteneyck
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 31 March 2011 - 08:38 PM

Let me restate that:
When I tried to download the AVG remover software you recommended I got the message "The Pipe State is Invalid".

Yes, I did try your advice.

#8 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,725 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:00 PM

Posted 31 March 2011 - 08:43 PM

Download, or run it?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#9 dteneyck

dteneyck
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 03 April 2011 - 04:06 PM

It happens when I run it. This is true of all software that we try to download and run.

I suspect that the problem is in AVG but don't know for sure. If it's not, and I remove AVG and try to reload it then I'm afraid that I may not be able to reload it because of this error and I won't have ANY virus protection. I need to be sure.

#10 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,725 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:00 PM

Posted 03 April 2011 - 04:17 PM

There are some other free AV programs out there, less problematic than AVG.
- Avast! free antivirus: http://www.avast.com/eng/download-avast-home.html
- Avira free antivirus: http://www.free-av.com/en/download/1/avira_antivir_personal__free_antivirus.html

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#11 dteneyck

dteneyck
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:02:00 AM

Posted 04 April 2011 - 09:05 PM

So where does the message "The Pipe State is Invalid" come from? Is it from AVG?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users