Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Net Framework Service Packs hang at Registering System.Enterprise.dll


  • Please log in to reply
1 reply to this topic

#1 estah

estah

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:23 AM

Posted 25 March 2011 - 11:47 PM

Hello,

Net Framework Service Packs hang at Registering System.Enterprise.dll
This computer had all the service packs and the current udates. What happened to it I don't know. I was downloading priorty updates on the Microsoft Windows update site, when it could not download a update. I contacted Microsft support and was told to download the dotnetfx_cleanup tool.zip which I did & did all the steps Microsoft support said to do. Then i began to install the Microsoft .NET Framework Version 1.1 Redistributable Package + two more in order. It hung at Registering System.Enterprise.dll. So I downloaded DetectDotnet.zip to see what service packs the machine had. It said I did not have .Net Framework v1.0. I downloaded version1.0 and tried to install it, it too hung at Registering System.Enterprise.dll.-- Now begins the problem.

I no longer have any service packs on this machine, and cannot install them again because of Registering System.Enterprise.dll hangs.

I've done all these steps after visiting many forums and reading about this subject:

1. Ran the dotnetfx clean-up tool --multiple times & with the multiple reboots before the Net Framework v 1.0 install.

2. Ran the msifix (Microsoft Installer Repair program), and msicuu2.exe.

3. Scanned my computer with Super AntiSpy ware, and Avast Anti-virus.
4. Defragged the harddrive (one person at a forum i visited suggested it).

5. Manually removed all .NET files from computer and registry according to the MS knowledge base article numbers.

6. Turned off the 'Distributed Transaction Coordinator'.
7. Tried running install from the Windows update website, installation still hung up-- left on one hour-- and the progress bar went half way and stays there.

8. Disabled all unneeded start-up items via WinPatrol.

9. Uninstalled, reinstalled Comodo Firewall.

10. Ended unneeded processes in Task Manager.

11. Turned off DEP.
12. Did the correct edits to the boot.ini file. I changed it back when this one didn't work.

13. Did all the following via the Run line:
regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wuaueng1.dll
regsvr32 wucltui.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll
Again turned off Avast Anti-Virus & Comodo firewall, then:

tried for 5th time to install The .Net Framework v 1.0 and it still hung at Registering System.Enterprise.dll and it would not install.
tried for 4th time to install The .Net Framework v 1.1 and it still hung at Registering System.Enterprise.dll and it would not install.
I am now having problems getting on the internet--browsers IE 8 & Firefox won't completely load some websites.
I'm at a loss of what to try next. Any help would be greatly appreciated.

Does anyone know the f button to push to bring this Dell machine to a factory Windows Xp Home refresh state. I am trying too get this computer up and running for my sister, who is on a limited monthly income.

estah

Edited by estah, 25 March 2011 - 11:50 PM.


BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:05:23 PM

Posted 26 March 2011 - 12:50 AM

Scanned my computer with Super AntiSpy ware, and Avast Anti-virus.

Hi estah and welcome -
You have cut down the options that would normally be given :wink: -
From all that you have listed I assume that NO .Net items are in Add / Remove now -
First - Have you yet used (or been able to download) Malwarebytes Anti-Malware Updated and then run a quick scan -
Next, you do not mention running chkdsk /r , to check and repair any other problems within your system -
Also a sfc /scannow check (but most Dell units have no CD) -
Someone else will give you the F button to press for a Dell (I think it is F10) -

Thank You -




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users