Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Virus Hijacked Antivirus software


  • Please log in to reply
No replies to this topic

#1 cfp98

cfp98

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:40 AM

Posted 24 March 2011 - 11:04 AM

It started out with my antivirus throwing up a malware warning error after visiting a reputable website, i used Avira to remove the threat and thought nothing more of it. I came back to my computer after about 3 hours and there were 40+ internet explorer windows open. I then ran a spybot scan and removed the malware entries in my registry that it threw up (i googled it and it came up saying that it was some security scam thing from 2008). Whilst i was in spybot i had a look at other settings and stopped a process running from my documents and settings folder called KTOYOI.exe so i disabled that and restarted pc.

Upon rebooting i noticed that the Avira antivirus hadnt started, i was unable to start it from the program. I tried to start it from services.msc and when i try to load that i get an internet explorer error saying 'one or more active x controls couldnt be displayed because either my current security settings prohibit running active x on this page or you have blocked a publisher of one of these controls.

Things that i have tried:

- safemode; I got the same error.

- diagnostic startup from msconfig and this error got thrown up; An access denied error as returnd whilst trying to change a service. you may need to log on using an admin ac to make the specified changes.

- reinstalling windows, i boot from the cd and it goes through its load and then gets stuck and says that the ftdisk.sys is corrupt press any key to continue and then the system restarts.

- chkdisk /r; I ran the 5 steps of this not sure what the results were as it had rebooted/continued with start up before i had a chance to read them.

- gparted; i tried booting into the software to see if it would have been possible to just delete the partition that i have windows installed on. When booting into this it throws up lots of errors on lots of different clusters. It then asks me about what keymap to use and then it runs a bit more of the bootup but then hangs.

- recovery console; i tried installing this from the xpcd and an error occured copying the file fdc.sys to C:\$WIN_NT%.~BT\fdc.sy_

A ideas where i can go from here?

Edited by hamluis, 24 March 2011 - 11:12 AM.
Moved from XP to Am I Infected.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users