Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

win 7 slow shutdown


  • Please log in to reply
3 replies to this topic

#1 terrordv

terrordv

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:08 AM

Posted 22 March 2011 - 05:41 PM

after i installed a few windows 7 themes shutingdown takes a long time like 5 minuits didnt used to be like that. im not sure where to start to fix it. thanks

i downloaded the themes from
http://windows.microsoft.com/en-us/windows/downloads/personalize/themes

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,589 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 PM

Posted 22 March 2011 - 05:43 PM

What happens if you uninstall the themes?

Here are some things you can try. Before editing the registry, be sure to either create an image of your system partition or backup the registry. If you don't know how, please ask.


1) Make sure "clear pagefile at shutdown" is not enabled:
start - run - regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

Set ClearPageFileAtShutdown value to 0


2) Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000

#3 terrordv

terrordv
  • Topic Starter

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:08 AM

Posted 22 March 2011 - 06:05 PM

dont seam to have the AutoEndTasks entry in the HKEY CURRENT USER\Control Panel\Desktop string and not sure where to find HungAppTimeout.

but the first string you said to edit fixed it thank you. :D

Edited by terrordv, 22 March 2011 - 06:16 PM.


#4 Allan

Allan

  • BC Advisor
  • 8,589 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:08 PM

Posted 23 March 2011 - 06:37 AM

Then don't worry about the other entries. Clear Pagefile at Shutdown will cause a major lag - and it is a completely unnecessary function for 99.99% of users. Glad you're back in shape.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users