Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

error with themes service


  • Please log in to reply
3 replies to this topic

#1 koliploik

koliploik

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:09:47 AM

Posted 21 March 2011 - 05:53 PM

Hi,
I have a problem with Themes service

if I click on Start button in the Themes service it return with error:
Error 1083: the executable program that this service is configured to run in does not implement the service.

what can I do ??
Thanks

BC AdBot (Login to Remove)

 


#2 Jacee

Jacee

    Bleeping around


  • Malware Response Team
  • 3,716 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:01:47 AM

Posted 22 March 2011 - 04:56 PM

Type services.msc in the start search box. click on the icon. when the window opens, right click on 'Themes', choose properties, then set it to automatic in the drop down box... now click start. Click apply and ok.

MS_MVP.gif
MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop


#3 Jacee

Jacee

    Bleeping around


  • Malware Response Team
  • 3,716 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:01:47 AM

Posted 22 March 2011 - 05:10 PM

You may also need to run System File Checker (sfc.exe) in an elevated command ... Right click on command prompt, choose to run as Administrator, type or copy/paste sfc /scannow and press 'enter key'.

MS_MVP.gif
MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop


#4 koliploik

koliploik
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:09:47 AM

Posted 22 March 2011 - 05:31 PM

I've already try this but it didn't resolve the problem.

But today I avvived to a solution:
the problem was that in the registry
in this key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost - NetSvcs
the value Themes under the key netsvcs was missed

this is the wrong config of netsvcs:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost - NetSvcs
AeLookupSvc
CertPropSvc
SCPolicySvc
lanmanserver
gpsvc
IKEEXT
AudioSrv
FastUserSwitchingCompatibility
Nla
NWCWorkstation
SRService
Wmi
WmdmPmSp
TermService
wuauserv
BITS
ShellHWDetection
LogonHours
PCAudit
helpsvc
uploadmgr
iphlpsvc
seclogon
AppInfo
msiscsi
MMCSS
EapHost
ProfSvc
schedule
hkmsvc
winmgmt
browser
BDESVC
AppMgmt


and this is the right configuration:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost - NetSvcs
AeLookupSvc
CertPropSvc
SCPolicySvc
lanmanserver
gpsvc
IKEEXT
AudioSrv
FastUserSwitchingCompatibility
Nla
NWCWorkstation
SRService
Wmi
WmdmPmSp
TermService
wuauserv
BITS
ShellHWDetection
LogonHours
PCAudit
helpsvc
uploadmgr
iphlpsvc
seclogon
AppInfo
msiscsi
MMCSS
wercplsupport
EapHost
ProfSvc
schedule
hkmsvc
winmgmt
browser
Themes <--------- this was the missing key
BDESVC
AppMgmt


Thanks a lot for the reply




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users