Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Diagnostic Virus


  • Please log in to reply
3 replies to this topic

#1 paulpsb

paulpsb

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 20 March 2011 - 05:44 AM

Hi all

I have the windows diagnostic virus on my home office PC (other PCs on our small home network are OK) "I'm assuming the kids have brought it to the party by downloading music & video from unknown sources. I regularly run C-Cleaner and Malwarebytes periodically on all our PCs and cant understand how this has infected this particular PC?

I've attempted to install the r-kill and then Malwarebytes removal tools. However, the following occurs in both safe and normal modes:-

Following re-boot (safe & normal)all my desktop icons have disappeared and only recycle bin and computer icon is left. When left clicking start, I also have access to outlook and explorer - program folder states "Empty"

When I download r-kill it starts OK in dos with an windows error message stating the program has stopped working and windows is looking for a solution. following lots of attempts, it will sometime say access denied and AVG detects malware infection "I've tried it with AVG disabled" Following a few moments the r-kill gives a report and says it has completed. However, at the same time the screen goes black leaving me with only explorer window open. I have no access to any other programs or icons?


Using explorer I attempt to download and save Malwarebytes to the desktop. Whilst it appears to download to desktop OK, I cant access it due to black/blank screen. I have attempted to run malwarebytes direct from the site. However, this gets so far and stops giving me ACCESS DENIED.

Ive taken photo's of most of the screens and Hope someone out there can help me?

Thanks

New Info: I've managed to run malwarebytes and super-antivirus and they both found and removed various infections, etc. However, whilst the PC appears to run OK all my programs are not listed and the icons are not displayed ? Its like they are been hidden ? but still working and listed in my add/remove program/features list. When I attempt to find them in program folders they are not listed ?

Would appreciate any help anyone can offer

Edited by paulpsb, 20 March 2011 - 11:18 AM.


BC AdBot (Login to Remove)

 


#2 Blade

Blade

    Strong in the Bleepforce


  • Site Admin
  • 12,704 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US
  • Local time:12:52 PM

Posted 28 March 2011 - 12:47 PM

Hello.

Please download UnHide.exe by Grinler to your Desktop. This utility will reverse changes to your system made by the infection.

Once downloaded, please execute the utility by double clicking on it.

After running it, your files should reappear. Let me know if they do not.

~Blade

Posted Image

If I am helping you, it has been 48 hours since your last post, and I have yet to reply to your topic, please send me a PM
Become a BleepingComputer fan: Facebook
Follow us on Twitter!
Circle us on Google+


#3 paulpsb

paulpsb
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 03 April 2011 - 08:21 AM

Hi Blade

Thanks for that i've been manually trying to make the files visible again "slow process"

Just ran the programme and the files are all back. Also the PC appears to be running faster??

Once again thanks mate

Best wishes Paul

#4 Blade

Blade

    Strong in the Bleepforce


  • Site Admin
  • 12,704 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US
  • Local time:12:52 PM

Posted 04 April 2011 - 10:53 AM

Glad I could help!

Posted Image

If I am helping you, it has been 48 hours since your last post, and I have yet to reply to your topic, please send me a PM
Become a BleepingComputer fan: Facebook
Follow us on Twitter!
Circle us on Google+





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users