Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New ISP, router will only connect one computer at a time


  • Please log in to reply
1 reply to this topic

#1 bluedrgn

bluedrgn

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:58 PM

Posted 13 March 2011 - 10:40 PM

today a friend of mine switched providers from Bell to Teksavvy and I agreed to help set it up. There were a few issues and tech support ended up putting the modem (a speedtouch) into bridge mode to allow the Linksys WRT54G to connect through PPPoE. Everything seemed perfectly fine until we realised that only one computer would connect to the internet at once. I rebooted and reset the router to default and upgraded the firmware. It should be noted that the 'active' computer would switch every time we did a full reboot of the modem. Out of a possible 3 it just kept switching. All of the settings appeared to be in order and I made sure that DHCP was disabled, so IP addresses should have been manually assigned. A few things didn't work and I just couldn't figure out this bizzarre situation. Also couldn't quite find an exact match of this problem on the internet. Any ideas on what could have changed or went wrong?

BC AdBot (Login to Remove)

 


#2 Orecomm

Orecomm

  • Members
  • 257 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Roseburg, Oregon
  • Local time:06:58 PM

Posted 14 March 2011 - 07:44 PM

Hello Blue,

Double check that the wire to the Speedtouch (now) bridge is plugged into the WAN port of your Linksys. It sounds like it's plugged into one of the four LAN ports. The Speedtouch will only recognize one MAC address on the inside in bridge mode. Normally that would be the MAC of the WAN port of your Linksys. If you hit the LAN side instead it will take the MAC of the first device that talks to it and ignore the rest. Since a router will rewrite the MAC address for all packets crossing the router to it's own the Speedtouch normally would see only the router's MAC, but if you are on the bridged LAN side it will see each PC plus the LAN MAC of the router. I'm not quite sure how you are getting the PPPoE connection to come up, but unless there are some other connections in your network it almost has to be miswired. One other remote possibility is that you are using DHCP to address your PC's and the Linksys is configured to only hand out one address. You can check the addresses on your PC's using Start->Run->ipconfig /all. They should all be 192.168.x.y where x is by default 1 and y is different from device to device and not the same as your router, 0, or 255. If it's a 169.254.xxx.xxx you aren't getting a DHCP address assigned, and if it's something else you are probably getting a public address from your ISP, which should only happen to your router's WAN port.

I just noticed that you said you disabled DHCP on the router. Why ? If you manually assign the addresses they must be in the same subnet as the LAN port on the router, have unique last octets (last digit) and NOT 0, 255, or the address used by the router, have the same mask (usually 255.255.255.0), and have the gateway assigned to the LAN IP address on the router.

Edited by Orecomm, 14 March 2011 - 07:47 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users