Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black screen when I click FLY NOW with MS combat flight sim 2.


  • Please log in to reply
9 replies to this topic

#1 skymaster191

skymaster191

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 11 March 2011 - 12:21 AM

I have Windows 7 Home premium and an XFX ATI Radeon HD 5670 graphics card. I am having difficulty with Microsoft Combat Flight Simulator 2 Pacific Theater. It loads up fine. Then when I click FLY NOW, I can see the cockpit control panel. But the rest of the screen is black, and I am unable to play. I tried adjusting display settings on the simulator software, and I also switched the software to Windows 7 compatibility mode. Nothing helped.

When I installed the video card, I only used the drivers CD. I did not download latest drivers from Internet. Could this be the problem, or am I looking at a compatibility issue with Windows 7? The monitor display otherwise works fine.

BC AdBot (Login to Remove)

 


#2 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 11 March 2011 - 12:39 AM

That sounds similar to a problem a Client of mine had with one of MS`s flight simulatiors.

The game would start fine. Then when it was time to fly you had sound. If you attempted to take off you heard all the proper engine sounds but of course crashed every time because you could not see anything.

Come to find out there was a setting for foggy\bad weather conditions. It was turned on.

Since you can see the cockpit control panel it sounds more like you have it set for night\instrument flight. Do`t think there is anything wrong with your video or PC.

#3 killerx525

killerx525

    Bleepin' Aussie


  • Members
  • 7,220 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Melbourne, Australia
  • Local time:09:13 PM

Posted 11 March 2011 - 12:42 AM

You could try updating the driver.

>Michael 
System1: CPU- Intel Core i7-5820K @ 4.4GHz, CPU Cooler- Noctua NH-D14, RAM- G.Skill Ripjaws 16GB Kit(4Gx4) DDR3 2133MHz, SSD/HDD- Samsung 850 EVO 250GB/Western Digital Caviar Black 1TB/Seagate Barracuada 3TB, GPU- 2x EVGA GTX980 Superclocked @1360/MHz1900MHz, Motherboard- Asus X99 Deluxe, Case- Custom Mac G5, PSU- EVGA P2-1000W, Soundcard- Realtek High Definition Audio, OS- Windows 10 Pro 64-Bit
Games: APB: Reloaded, Hours played: 3100+  System2: Late 2011 Macbook Pro 15inch   OFw63FY.png


#4 skymaster191

skymaster191
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 11 March 2011 - 12:52 AM

Yeah, same here. I can hear sounds but I can't fly. It's not set up for night/instrument flight. I have a new PC that I built that runs perfectly, and I have a new monitor also.

#5 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 11 March 2011 - 01:05 AM

Have you checked the MS Flight Simulator site for any updates\patches?

#6 skymaster191

skymaster191
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 11 March 2011 - 10:58 AM

What's the website and phone numkber for MS Simulator support?

#7 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 11 March 2011 - 11:26 AM

Google says this is a good place to start.

#8 skymaster191

skymaster191
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 11 March 2011 - 12:15 PM

Thanks, if I have to spend more money on Windows XP mode CD to run games. I'm making a complaint on MS. I'm sick of their BS business practices and forced upgrades

#9 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:13 AM

Posted 11 March 2011 - 12:27 PM

Thanks, if I have to spend more money on Windows XP mode CD to run games. I'm making a complaint on MS. I'm sick of their BS business practices and forced upgrades



Should`t cost you a dime.

#10 MickinPlymouthUK

MickinPlymouthUK

  • Members
  • 683 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:13 AM

Posted 21 March 2011 - 11:09 PM

CFS2 runs fine for me (I'm Win XP),it's a 10-year old game but has still got a thriving community, you could try asking at their forum- http://205.252.250.26/cgi-bin/yabb2/YaBB.pl?board=cfs2




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users