Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Win7/Linux system will not boot


  • Please log in to reply
No replies to this topic

#1 crosswind

crosswind

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:31 AM

Posted 10 March 2011 - 05:27 AM

Hi guys,

I'm sorry this is kind of weird and long winded, but I don't know what do do and I could really use some help :)

I have a Dell Studio 1558 laptop which came with three HDD partitions - a utility partition, a recovery partition (which was set to Active) and the OS partition with Windows 7 Pro installed on it.
I was really determined to triple boot Windows 7, Ubuntu and a Hackintosh system and last week I got to it. My Windows OS was full of junk, so I used the recovery utility (Dell DataSafe Local Backup) to restore the system to its factory state. It worked. Great.
I got on GParted and deleted the utility and recovery partitions, and moved the OS partition to the front of the drive. Unsurprisingly any attempt to boot the computer was met with BOOTMGR MISSING. I used the Windows 7 install DVD to install the Windows bootloader onto the Windows partition. The computer booted Windows fine.
Got out GParted again, shrank the Windows partition to 55gb, set up two more 55gb partitions after it, then allocated the rest of the drive space as a shared partition (for data all three operating systems will use.)
So sda1 was Windows 7 Pro, sda2 was blank HFS+ partition, sda3 blank ext4 partition, and sda4 blank ntfs partition.
I installed Ubuntu onto sda3, and the GRUB bootloader with it. I then had a working Win7/Ubuntu dual boot system. This afternoon, everything was working absolutely perfectly.

I booted into Windows intending to uninstall the junk from Dell and load my own programs onto it. I was about to get cracking when Dell DataSafe Local Backup decided to update itself, and in the process, 'install files into the recovery partition'. I have absolutely no idea what it did, but now my computer doesn't boot. I get the Dell screen and I can access the BIOS and the boot menu, it boots off a live CD just fine, but if I go past the Dell screen I get a black screen with a flashing white cursor - no error message to tell me what I've done.

I assumed it had somehow screwed my bootloader, so since I'd been using GRUB, I put in the Rescatux live CD and attempted to reinstall GRUB. I was met with error messages. I then tried the Windows 7 install DVD, but it reported that it was unable to find a startup problem and that Windows booted fine. I have absolutely no idea what to try now.

My options, as I see them, are as follows.
1) Restore the image of the Windows partition that I took immediately after restoring it to its factory state and installing the Windows bootloader onto it. (If the problem was on the Windows partition, wouldn't hte install disk have fixed it?)
2) Use GParted to rewrite the MBR (I don't fully understand what the implications of this are, or know what it is.)
3) DBAN, repartition and restore the images. (I'd really like to avoid this because I don't know how to repartition and reinstall operating systems onto a drive after DBAN.)

If anybody can tell me what that @#*!ing program did to my PC and how I can get it to boot again, I will be eternally grateful :) Thanks all!

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users