Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sudden problem playing H.264/AVC files


  • Please log in to reply
5 replies to this topic

#1 The Shining Wizard

The Shining Wizard

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 08 March 2011 - 05:40 AM

Just until two weeks ago I was having no problem playing 720p files (be it MKV or MP4) but I don't know what happened, now suddenly I'm having a problem playing those same files. No matter which player I use, the video lags behind the audio or, in the case of VLC, the video constantly freezes for a second or two.

This is definitely not a codec problem as I had K-Lite Codec Pack Full installed for nearly a year and I was able to play everything just fine. Even so, I tried uninstalling that one, and installed CCCP, and there was no difference. I installed CoreAVC, and there is still no difference.

I'm on a Pentium 4, 2.93 GHz processor, with 2 GB RAM, no graphics card, just an Intel Graphics Media Accelerator Driver. All this was working just fine until two weeks ago.

The problem is so severe that I downloaded this video from youtube, it's in FLV format (but encoding is AVC) and even THAT doesn't play properly, either in Media Player Classic Homecinema or VLC or Splash Lite.

I've checked task manager while playing these files and CPU usage is almost always at 100% or somewhere between 90% - 100% and very rarely does it drop below that.

BC AdBot (Login to Remove)

 


#2 thrillhouse

thrillhouse

  • Members
  • 1,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Va
  • Local time:09:05 AM

Posted 09 March 2011 - 08:02 PM

this might be a long shot, but did you have a windows update recently? I have had it break codecs before. Also, are you 64 bit? I would uninstall all codecs, reboot, install, reboot, and give it a whirl.

#3 The Shining Wizard

The Shining Wizard
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 10 March 2011 - 06:10 AM

No, I've actually had windows updates disabled for a long time now... haven't updated in a long while. And no, this is 32-bit. I actually tried udpating a couple of days ago, I enabled automatic updates and all that, went to the Windows Update website and I was stuck with the "looking for updates for your computer" screen for like 40 minutes so I just closed Internet Explorer and went back and disabled WinUpdates again.

Actually, I'm not sure what's going on because I've only just noticed my computer doesn't seem to be running as smooth as it should be. About half a year ago, things were running much smoother, and thanks to having 2 GB RAM and such, I used to be able to run like 5 programs at the same time and my system would still be running smoothly, even big programs like Firefox and Windows Live Messenger etc. But now... I had Firefox and Skype opened earlier today and my PC was being slow as hell.

#4 thrillhouse

thrillhouse

  • Members
  • 1,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Va
  • Local time:09:05 AM

Posted 10 March 2011 - 06:29 AM

hmm, I don't know about system resources but skype always drags my internet speed down. I have a meter that shows when I am downloading and skype constantly downloads and uploads at about 15 Kb/s (which I consider significant, what is it downloading or doing?)

Anyway, do you have Gspot with the Codec Tools that come with the k-lite codec pack? You can use Gspot to see if the codecs for the videos you have are installed properly. If you don't have it already you can get it here:

http://fileforum.betanews.com/detail/GSpot/1088774248/1

One thing that helped me get my computer running was a program called quick startup and another called secunia psi. QS can identify which startups are bad or useless and easily disable and re enable them. PSI scans all your programs and updates them all at once and gives you a rating of how up to date your computer is.

IMO 2gb of ram is a minimum these days, you may want to try turning off hardware acceleration. The setting is in the display properties but varies per OS.

#5 The Shining Wizard

The Shining Wizard
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 10 March 2011 - 10:33 AM

GSpot says "codec status undetermined" but it plays the video if I click on the "MS A/V" buttons. However, while playing, the color of the video (in GSpot) keeps changing... like, the yellow tones of the opening shot go green a few seconds in. But anyway, again, VLC should be able to play these files and, in fact, WAS playing these files until just a couple of weeks ago... now it stutters and freezes every few seconds.

I tried disabling Hardware Acceleration, tried putting it at several different settings, but none of them seem to have worked... the H.264/AVC files STILL seem to be eating up the CPU. The media players don't seem to be using much of the page file/virtual memory, just the CPU.

Also, what the heck is "write combining"? That seems to be enabled.

It's funny - I used to have 256 MB (DDR1) RAM, and I knew it was too low so that's why I upgraded it to 2 GB (DDR2) last year. My computer ran so much better and smoother then.


And I posted a more detailed account of this problem on the VLC forum... no replies so far.

Edited by The Shining Wizard, 10 March 2011 - 10:36 AM.


#6 The Shining Wizard

The Shining Wizard
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:08:05 AM

Posted 11 March 2011 - 05:59 AM

Never mind. Figured out the problem. CPU overheating - took a vacuum cleaner and blew all the dust out from inside of it, now the videos play fine.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users