Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

XP Slow Shutdown leading to Registry corruption.


  • Please log in to reply
6 replies to this topic

#1 HavokTheorem

HavokTheorem

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 07 March 2011 - 04:14 PM

Ok, so heres the deal. This morning I turned on my PC, and the PSU fan was grating like a truck engine. I wasnt worried by this, as it happens from time to time (if someone wants to interject why it does this, go ahead), so I waited until XP booted up and then pressed start, turn off, shut down.
Now, whenever I want to turn of my computer it's a manual procedure, as 1 or 2 popups saying 'closing application' pop up asking for me to end them, even if I have closed all my applications. Does anyone know why there are so many things to be closed manually (like iTunes Helper, system DLL's, backround apps) when it should really be the very shutdown's job to close these without a huge status bar?

Anyway, since it was taking about a minute to even start shutting down and I was getting annoyed by the grinding of the fan, I did the old hold down the power button trick we all so loved doing a few years ago. It switched off the computer, but when I rebooted (the fan was working fine now) I got a dreaded error screen, and I thought I had screwed my registry, exactly like I had a few months ago when my computer again was taking millenia to turn off, meaning a whole hard reset and loss of gigabytes of data. Thankfully it just asked me to reduce my CPU clock (which was overclocked by a whopping 30mhz) and then told me that Registry files had been damaged, but they had been recovered from copies successfully.
Can anyone tell me what causes XP to shut down so frustratingly slowly with several popup messages,
and any possible reasons why using a forced shutdown seems to mess with my registry to the point I'm afraid of switching off?

Thanks.

(PS I plan to upgrade to 7 sometime in the future, so hopefully it is a bit more advanced.)

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,551 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:16 PM

Posted 07 March 2011 - 04:19 PM

To Speed Up Windows Shutdown:


1) Make sure "clear pagefile at shutdown" is not enabled:
start - run - regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

Set ClearPageFileAtShutdown value to 0


2) Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000

Edited by Allan, 07 March 2011 - 04:19 PM.


#3 Allan

Allan

  • BC Advisor
  • 8,551 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:16 PM

Posted 07 March 2011 - 04:20 PM

By the way, if I were you I'd be concerned about the fan / power supply

#4 HavokTheorem

HavokTheorem
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 08 March 2011 - 06:05 AM

Cheers, exactly what I was looking for. And about the PSU, is it a good idea to ignore the big red label saying 'never ever open no matter what'?

#5 Allan

Allan

  • BC Advisor
  • 8,551 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:16 PM

Posted 08 March 2011 - 07:44 AM

Why would you be opening it? You should try a different psu.

Edited by hamluis, 08 March 2011 - 09:21 AM.


#6 HavokTheorem

HavokTheorem
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 08 March 2011 - 05:47 PM

Right. That would probably be a good idea. I will hopefully get my hands on some cash to upgrade my computer a bit soon.

#7 Allan

Allan

  • BC Advisor
  • 8,551 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:16 PM

Posted 08 March 2011 - 05:56 PM

All you need to do is purchase a new psu from a retailer who will accept a return if you don't need it. You only pay for it if it solves the problem ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users