Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Odd problem - virus altering mouse buttons?


  • Please log in to reply
No replies to this topic

#1 JeremyC

JeremyC

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:39 PM

Posted 06 March 2011 - 12:04 PM

Hi there.

About a week ago, I got the "Security Tool" virus, and after following the guide on this site, I managed to get rid of it. I have since run another Malwarebytes' Anti-Malware scan, run a Home Intruder scan, and have installed Avast (and done a scan). Eventually, they stopped finding infections, so I assumed I was free of viruses. But I've not been able to shake the feeling that something was not quite right. For instance, I downloaded the Rkill (renamed Iexplore.exe) program, and I would notice that it would simply disappear, or the shortcut to it would become invalid. I put this down either to paranoia, or a virus trying to stay on my system.

I ignored my paranoia, as I'd run so many virus scans and was frankly getting sick of fighting with the computer. However, today when I turned on my computer, I noticed the middle mouse button wouldn't open a new tab in Chrome, as it would normally do. Fair enough I thought; Windows must be having a bad day. But then I tried to click on another tab (with the left mouse button), and instead of switching to it, it closed it. Then I noticed that clicking hard with the LMB would enable the scroll feature (you know, the one where you have a circle in the centre of the screen with four arrows pointing in each direction), which is something the middle mouse button should do. And now, it occasionally won't let me click on things in my toolbar. I can hover over them, but it just doesn't respond to me clicking. It is temporarily solved by ending and restarting explorer.exe, but invariably comes back. The same with shutting the laptop and logging back in. The only consistent thing is that the middle mouse button does not respond to button presses; only scrolling.

This is getting pretty frustrating as I am in the middle of doing an essay, and it is sometimes impossible to highlight text, and do other simple tasks.

Is this a virus, or simply a hard/software fault?

N.B. I have tried a different mouse, and have used the built-in touchpad, and all produce exactly the same results, so I doubt it is a hardware fault.

I am running Vista on a Dell Studio Laptop, and like to think of myself as reasonably technologically proficient, so I haven't uninstalled the mouse drivers or anything!

I tried going into Control Panel, but the only useful options there were to switch primary and secondary mouse functions. I did that, and still had the same problem.

Sorry for the long essay, just trying to give as much info as possible (though I think I've given my life story!).

I would be so grateful if anybody could give me so advice/guidance - it's a really frustrating problem!

Cheers,

Jeremy

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users