Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Access Some Websites


  • Please log in to reply
14 replies to this topic

#1 jctan

jctan

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 01 March 2011 - 03:22 PM

Hello,

When I go to google.com or gmail.com I get error "Error 101 (net::ERR_CONNECTION_RESET): Unknown error."
I can access yahoo.com and other various sites. Clicking on the links also work, but when I use the searchbox of say yahoo or msn, same issue is encountered.

I've tried below fixes but they didn't resolve the issue:
- repair the connection by left-clicking on the icon on the taskbar.
- used the cmd command to do netsh winsock reset / netsh winsock reset catalog.
- went to LAN settings to uncheck all, or to select "Automatic detect settings" only.
- ensured IP & DNS Server addresses set to automatic.
- renamed C:\windows\system32\drivers\etc\HOST.bak to something else.

I have another PC connected to the same modem/router and it's working well.
PC in question is running on XP Home SP3. Thanks!!!

BC AdBot (Login to Remove)

 


#2 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 01 March 2011 - 03:29 PM

Hi jctan,

If you renamed this file "C:\windows\system32\drivers\etc\HOST.bak" to something else, you really didn't change anything.

The .bak extension on the HOSTS file means that was already a backup.

I would like you to go here and read and follow the instructions on how to update/replace your "HOSTS" file.

You may want to try resetting both TCP/IP and Winsock on your computer to help with your troubles.
To successfully complete this, you will need to be at a command prompt.
Click on Start then Run. In the Run box type CMD and press enter.
You will now see a black window with one line of text and a blinking cursor.

You will next type:

  • netsh int ip reset tcp.log

This will reset your TCP/IP settings.

Next you will reset Winsock:

You will type:

  • netsh winsock reset sock.log

When the Winsock is finished you will be directed to restart your computer. Type exit in the window and press enter.

From here you will do a normal restart on your computer and retest your network connection.

Hope this helps,
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,565 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:33 PM

Posted 01 March 2011 - 03:36 PM

From what I see, it's a browser problem, Google Chrome.

I would try uninstalling it and using a different browser.

Louis

#4 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 02 March 2011 - 03:02 PM

Hi techextreme,
I see. You're right, it was the .bak file I renamed.
I also looked into that hosts.bak file before renaming.
Google isn't listed there and the rest of the sites listed sounded suspicious so I think this is not the issue?

Anyway, I reset both TCP/IP and Winsock using the commands you posted and restarted but no effect.
I also followed the instructions on replacing hosts file and restarted. Also no effect.

Hi hamluis,
Issue exists whether I use Chrome or IE..

FYI, PC had recently been infected with virus, but it seems clean now.
Also some programs were updated/downloaded such as Avast, MBAM, HijackThis..

I tried to create a HijackThis log but encountered error:
"For some reason your system denied write access to the Hosts file. If any hijacked domains are in this file, HijackThis may NOT be able to fix this.
If that happens, you need to edit the file yourself. To do this, click Start, Run and type:
notepad c:\WINDOWS\System32\drivers\etc\hosts
and press Enter. Find the line(s) HijackThis reports and delete them. Save the file as 'hosts.' (with quotes), and reboot.
For Vista: simply, exit HijackThis, right click on the HijackThis icon, choose 'Run as administrator'."

Then it will allow me to continue with the scan, but will show the following message:
"Your hosts file has invalid linebreaks and HijackThis is unable to fix this. O1 items will not be displayed.
Click OK to continue the rest of the scan."


#5 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 02 March 2011 - 03:32 PM

jctan,

Let's try one more thing.

Please download HostsXpert 4.3
  • Extract (unzip) HostsXpert.zip to a permanent folder on your hard drive such as C:\HostsXpert
  • Double-click HostsXpert.exe to run the program.
  • Click "Restore MS Hosts File".
  • Click OK at the confirmation box.
  • Click "Make ReadOnly?".
  • Click the X to exit the program.
-- Note: If you were using a custom Hosts file you will need to replace any of those entries yourself.

Also, let's wait on the HJT logs for now. If we need to go that far, we'll have to move this to another spot in the forums as they're not permitted here.

Hope this helps,
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#6 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 03 March 2011 - 10:32 AM

Tried to run HostsXpert.exe and I get error:
"Your HOSTS file is marked as a "system file" and can NOT be manipulated.
Press OK to remove the system file attribute, CANCEL to Quit.

***HostsXpert will NOT reset these attributes.***"


The confirmation box comes up twice so I press OK twice, then 66 lines come up on the HostsXpert window, which include a host of google and search.yahoo addresses.

Tried to continue Restore MS Hosts File and I get error:
"ERROR: Cannot create file C:\WINDOWS\system32\DRIVERS\ETC\hosts"

Edited by jctan, 03 March 2011 - 10:33 AM.


#7 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 03 March 2011 - 11:55 AM

Hi jctan,

From this line here:

"Your HOSTS file is marked as a "system file" and can NOT be manipulated.
Press OK to remove the system file attribute, CANCEL to Quit.


We can see that your existing Hosts file has already been marked Read-Only.

We need to change this to Writeable or "Non-Read-Only".

So let's open up HostsXpert again and click on:
Posted Image

The next thing we want to do is make a backup of what you have there now. Click on:
Posted Image

This will make a backup of your existing HOSTS file.

Next click on:
Posted Image

You will not see a listing for MVPS Hosts. Click on MVPS Hosts and click on replace:
Posted Image

You may or may not receive a warning regarding your DNS Client Service that looks like this:
Posted Image
For now, disregard this warning and click OK.

The next screen you will see is:
Posted Image
Once again, click on OK.

This will download and replace your existing HOSTS file with the tried and true Microsoft MVPS Hosts file.

Once that has completed, click on File Handling and then "Make Read-Only"
Posted Image

Close HostsXpert and reboot your computer. Once rebooted, once again try accessing Google and let me know how things go.

IF at anytime during these directions you get an error, please stop and notify me. I will help you get through it.
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#8 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 07 March 2011 - 12:41 PM

I clicked on Make Writable and nothing happens.
I tried the next step but Backup / Restore cannot be clicked...

#9 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 11 March 2011 - 04:49 PM

Checked LAN Settings, and it is set to automatic. No other checkbox is checked.
Also checked Restricted Sites and tried to compare its list to that of my current Hosts file. Restricted Sites look legit.
Since HostXpert has scanned my current Hosts file to contain legit sites that shouldn't be there, then indeed the Hosts file is the issue?
The only thing is I can't make it readable or overwrite it..

#10 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 15 March 2011 - 07:59 AM

jctan,

We're gonna take a good look at your HOSTS file.

Click on Start then Run.

In the run box type "CMD" ( without the quotes ). You will now see a "Dos Prompt" with the cursor flashing behind c:\windows\system.

In the DOS Window, I'd like you to type: CD C:\Windows\system32\drivers\etc and press enter.

Now, type attrib hosts and press enter.

Tell me what the output is in your reply.
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#11 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 16 March 2011 - 11:38 AM

Output is: A SHR C:\WINDOWS\system32\drivers\etc\hosts

I tried fixing hosts files before by pasting a clean hosts file to this folder but getting error indicating that such a file already exists.
I made sure 'show all hidden files' is selected so I can delete the problem file but it's still not showing up even when using Windows' Search function.
Hosts shows up in C:\i386 during search though, but I didn't want to touch it without further instructions.

Edited by jctan, 16 March 2011 - 12:31 PM.


#12 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 16 March 2011 - 12:59 PM

Hi jctan,

As I suspected it has some file properties set that it should not. So, Through our checking and testing, it seems that the permissions on your HOSTS file have been changed. This is stopping us from removing any unwanted/unneeded entries. So, we will use a utility named hosts-perm.bat.

So please click here - > hosts-perm.bat
Save the file to your desktop.
You should now see an icon similar to this on your desktop

Posted Image


Double click on the file and a DOS window will open and reset the permissions on your HOSTS file and once again allow us the ability to make changes.

Once this has finished, the existing HOSTS file should show up as viewable and modifiable in the folder.

I'd then like you to go to this post which contains the directions I gave you for HostsXpert to backup/restore and replace your HOSTS file with the MVPS HOSTS file.

Let me know the outcome.
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#13 jctan

jctan
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 16 March 2011 - 01:25 PM

WOWOWOW!!!!! Issue is resolved!!! Thank you techextreme soooooo soooooo very much!!! :thumbsup:

Edited by jctan, 16 March 2011 - 01:26 PM.


#14 techextreme

techextreme

    Bleepin Tech


  • Members
  • 2,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:11:33 PM

Posted 16 March 2011 - 02:22 PM

Hi jctan,

That's great news. Glad we got it sorted.
Techextreme

"Admire those who attempt great things, even though they fail."

-- Seneca

#15 hamluis

hamluis

    Moderator


  • Moderator
  • 56,565 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:33 PM

Posted 16 March 2011 - 03:12 PM

FWIW: I'd be concerned with the possibility of malware...if my hosts file was somehow modified without my intervention.

Nice work by TE :).

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users